mailto link is not rendered correctly (text overlap)

RESOLVED DUPLICATE of bug 288047

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 288047
13 years ago
13 years ago

People

(Reporter: Sébastien Stormacq, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

On some web pages, the mailto: links overlap the text preceeding it.
Example is on the last line of http://www.quantum-capture.co.uk/about.asp

Reproducible: Always

Steps to Reproduce:
1.Open the above URL
2.Check the last line
3.

Actual Results:  
The text embedded within the mailto: link overlap the end of the regular text

Expected Results:  
the text should be flozing left to right without overlaps
(Reporter)

Comment 1

13 years ago
Problem does not occur on Firefox - Linux, Solaris or Windows - Only Mac builds
WFM in:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006
Firefox/1.4.1
and newer builds.

Reporter, can you please attach a screenshot?
(Reporter)

Comment 3

13 years ago
Created attachment 200371 [details]
Screenshot showing the problem

The the last line : the copyright line.
the "Q" from the company name overwrite the "5" from 2005
URL = http://www.quantum-capture.co.uk/about.asp
Browser is Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5)
Gecko/20051006 Firefox/1.4.1
(Reporter)

Comment 4

13 years ago
Comment on attachment 200371 [details]
Screenshot showing the problem

In the last line of this image, we can see that the "Q" from the company name
is overlapping the "5" from the 2005
Browser : Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5)
Gecko/20051006 Firefox/1.4.1
URL : http://www.quantum-capture.co.uk/about.asp
Attachment #200371 - Attachment description: Screenshot shozing the problem → Screenshot showing the problem

Comment 5

13 years ago
WFM.
Please check font pref/userContent.css.

Mac OS X 10.3.9
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051020
Firefox/1.6a1

Camino trunk 2005102222 (v1.0+)
(Reporter)

Comment 6

13 years ago
Created attachment 200536 [details]
Another screenshot showing the same problem on a Mozilla.org web site

This screenshot shows teh same problem occuring on the mozilla.org web site.
User-Agent : Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
The letter-spacing in these screenshots is somewhat smaller than on my system (i.e. some places where I'm seeng two pixels between letters, the screenshots show only one). This is strange, as the fonts seem otherwise identical.

Sébastien, could you please try this in safe mode (http://kb.mozillazine.org/Safe_mode) and let us know if you're still seeing it?
(Reporter)

Comment 8

13 years ago
Same problem is safe-mode.
Might it be related to fonts I have installed on my system or other machine-specific issue ?
I have tried with a freshly installed powerbook and the problem is *not* reproducible.
I would agree to close this bug as the problem seems to only occur on my powermac.
However any help to troubleshoot this is welcome
Although I don't see the problem on the sites mentioned above, I came accross a page where I do see a very similar problem:
http://www.gnome.org/projects/epiphany/ (in the first paragraph, especially the last link there).
This page uses the "Bitstream Vera Sans" font, which is not a standard mac font - I have it installed in my user directory (the font is available from http://www.gnome.org/fonts/).
I can see the problem when the font is displayed in the default 12pt size. Using Cmd-+ or Cmd-- to change the size makes the problem disappear.

Sébastien - does the problem you see also disappear when changing font size? Are you using non-default versions of the Verdana and/or Arial fonts (used in the pages where you're seeing the problem)?
Actually, my problem (and probably the original problem as well) is bug 288047.
(Reporter)

Comment 12

13 years ago
Bingo!
You're right, this is all related to a font issue.  My problem seems to be due to bug <a href=https://bugzilla.mozilla.org/show_bug.cgi?id=288047">288047</a>.
Comment <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=288047#c8">#8</a> described a workaround that worked for me.
Thanks for having helped to debug this.  I am closing the issue. 

*** This bug has been marked as a duplicate of 288047 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.