links with target="_top" open in wrong frame after been back in history

RESOLVED DUPLICATE of bug 312117

Status

()

Core
Document Navigation
RESOLVED DUPLICATE of bug 312117
12 years ago
9 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
To reproduce:
- Open
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=nsHTMLDivElement.cpp&branch=&root=/cvsroot&subdir=mozilla/content/html/content/src&command=DIFF_FRAMESET&rev1=1.51&rev2=1.52
- click on the "blame" link in the bottom frame
- Go back in history
- Click again on the "blame" link in the bottom frame

Result:
The opened page is now suddenly opened in the bottom frame.

Expected:
It should just open like it did at the first time.

This regressed between 2005-10-07 and 2005-10-08:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-10-07+07%3A00%3A00&maxdate=2005-10-08+08%3A00%3A00&cvsroot=%2Fcvsroot
So very likely a regression from patches from bug 311269 and bug 292962.
(Reporter)

Comment 1

12 years ago
I haven't checked if this is a problem in branch (it should normally also happen
on branch). Could someone confirm (Peter?) if this is a problem in branch builds.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051020
Firefox/1.5 ID:2005102005

testcase comment 0 doesn't work on branch either

*** This bug has been marked as a duplicate of 312117 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(In reply to comment #2)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051020
> Firefox/1.5 ID:2005102005
> 
> testcase comment 0 doesn't work on branch either

b/s, this is WFM on branch

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.