Closed Bug 313264 Opened 17 years ago Closed 17 years ago

Malformed URL http// without colon redirects to http://www.microsoft.com and https without the colon redirects to https://www.paypal.com

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 231720

People

(Reporter: shughes, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

if you type http//www.getfirefox.com into the address bar you will be redirected
to http://www.microsoft.com - if you type https//bugzilla.mozilla.org/ into the
address bar you will be redirected to https://www.paypal.com/ -- malformed
headers should simply error out or at least attempt a correction.

Reproducible: Always

Steps to Reproduce:
1.simply type http//www.getfirefox.com into the address bar of Mozilla
2.simply type https//bugzilla.mozilla.org/ into the address bar of Mozzila
3.

Actual Results:  
1. redirected to http://www.microsoft.com
2. redirected to https://www.paypal.com/

Expected Results:  
error out

*** This bug has been marked as a duplicate of 231720 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.