Option to disable all plugins

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
13 years ago
13 years ago

People

(Reporter: gkw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

There should be an option button to disable all plugins through the Tools -> Options -> Downloads -> Plug-ins interface. I personally prefer to download all PDF files instead of viewing them through the browser.

Reproducible: Always
Severity: trivial → enhancement

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 189378 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
erm i'm not sure if i'm saying this correctly but what i meant was a 'Disable All' button. sure still a duplicate?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

13 years ago
That depends on what you really want:

If you are talking about disabling plugins embedded on the page (using OBJECT
or EMBED tags), this is not possible using the dialog you mention, see the
explanation in bug 236622. Adding this functionality is bug 19118.

If you are only talking about full-page plugins (i.e. what happens if you click
on a link to document that is handled by a plugin), this already works for each
plugin individually listed in the "Plug-ins" dialog. Adding UI there to uncheck
all plugins at once would be WONTFIX, since this dialog has been removed again
on the trunk (it is integrated with the download actions).

If you just want a way to completely disable all plugins unconditionally (this
is how I read your request), this is a dup of bug 189378. Doing this per site
is bug 94035.
(Reporter)

Comment 4

13 years ago
WONTFIX then, since what i meant was adding that UI to uncheck
all plugins at once.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.