Last Comment Bug 313510 - New version of JEP (0.9.5), please land on trunk and branches
: New version of JEP (0.9.5), please land on trunk and branches
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Josh Aas
:
Mentors:
Depends on: 320998
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-23 12:34 PDT by Steven Michaud [:smichaud] (Retired)
Modified: 2006-06-24 14:14 PDT (History)
7 users (show)
mscott: blocking1.8rc1+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Steven Michaud [:smichaud] (Retired) 2005-10-23 12:34:28 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20050920
Build Identifier: na

I've just released a new version (0.9.5) of the Java Embedding Plugin:

http://javaplugin.sourceforge.net/

It contains several fixes that weren't in the previous version (0.9.4+a) --
including workarounds for memory leaks from the JVM's garbage collector,
workarounds for issues that are triggered by the fix for bug 298961, and
workarounds/fixes for a number of crash bugs.

Please land JEP 0.9.5 on the trunk and branches as soon as soon as you can.
If possible, I'd really like the new version to be bundled with Firefox 1.5
RC1.  I realize that I'm squeaking in just before the deadline ... but JEP
0.9.5 would have been done a couple of days sooner if I hadn't had to deal
with the bug 298961 problems :-)

None of these issues is a show-stopper (none of them happens often enough).
But the bug 298961 issues and the crash bugs, at least, have the potential to
be visibly annoying.

(JEP 0.9.4+a is what's currently bundled with all Mozilla.org browsers on the
trunk and branches.)



Reproducible: Didn't try
Comment 1 Josh Aas 2005-10-23 22:20:50 PDT
Drivers - smfr and I think we should do this. We have < 2 hours until code freeze, not much I could do about that. If you see this, I'm on IRC and email until after the code freeze and willing to discuss this.

This is Mac only.
Comment 2 Mike Schroepfer 2005-10-23 23:10:51 PDT
Holding for now per discusison on email.   Want to make sure the changes are verified on trunk and are workign well before branch land.
Comment 3 Josh Aas 2005-10-23 23:52:25 PDT
Landed on trunk.
Comment 4 Daniel Veditz [:dveditz] 2005-10-24 07:31:44 PDT
-> josh since he's taken the initiative on getting this in.
Comment 5 Josh Aas 2005-10-24 11:04:19 PDT
Steven - which crashes does this solve?
Comment 6 Steven Michaud [:smichaud] (Retired) 2005-10-24 11:48:17 PDT
> which crashes does this solve?

1. In CEmbedded hostWindow (which I mentioned in the distro's Changes.txt and
   which only happens on OS X 10.4.x).

2. Several that I lumped together in item 2g of Changes.txt, which already had
   fixes in previous versions, but which I found still allowed crashes and
   therefore had to tighten up:

   a. In CWindow setState (see setState_AWTCW() and setState2_AWTCW() in
      Handlers.m).

   b. In CAppletWindow cleanup (see cleanup_AWTCAW() in Handlers.m).

   c. In CEmbedded cleanup (see cleanup_AWTCE() in Handlers.m).

   d. In ThreadUtiltiies/AWTModelUpdater registerModelForUpdate (see
      registerModelForUpdate_TU() in Handlers.m).

   e. In NSViewAWTContext tickFlusher (see tickFlusher_AWTCTX() in
      Handlers.m).

Like I said, none of these happens very often.  But in my tests I saw at least
one crash of each of these different kinds, when I did my
rapidly-changing-pages-with-lots-of-applets torture tests.

Possibly the most visible problem that JEP 0.9.5 fixes is one of the side
effects of the bug 298961 fix:  Open an applet.  Click once on it to put the
focus inside the applet.  Open a new tab from the menu (because the focus is
in the applet, you won't be able to use Command-T).  You'll find that you
can't enter text in the location bar.

If JEP 0.9.5 might be able to get into the final Firefox 1.5 release without
first being in RC1, I'd say that, if there's any substantial doubt about
0.9.5, it should be landed everywhere _except_ RC1.  Otherwise I'd say that
you should go ahead and land it in RC1, too -- with the option to revert back
to 0.9.4+a if 0.9.5 turns out to have regressions that outweigh its fixes.
Comment 7 Josh Aas 2005-10-24 14:33:18 PDT
To summarize the testing that this has had:
1) I have tested it a bit, and found no new problems.
2) smichaud has tested extensively it seems
3) various people, Mark Mentovai, Nate Weaver (wevah), have tested lightly and found no problem.

So, nobody has found any problems, but maybe we haven't tested enough. My gut tells me to land this because smichaud has delivered solidy on every JEP release in the past (iirc), and since Java is in a sorry state on the Mac we could use all the help we can get. However, I am a bit worried about the lack of extensive testing.
Comment 8 Asa Dotzler [:asa] 2005-10-24 14:44:47 PDT
approving conditional on further testing today proving that this makes things better and not worse.
Comment 9 Steven Michaud [:smichaud] (Retired) 2005-10-24 14:47:00 PDT
All right, then ... let me take the risk of shooting myself down :-)

What I'm most worried about is doing a Firefox 1.5 release (not a beta or an
RC) that contains known problems that I've already fixed.

I'm not terribly comfortable, either, putting a new JEP version into the hands
of tens of thousands of users without any more testing than I've been able to
do myself.  Not to say that I lack confidence in my testing -- I'm still
probably finding more bugs than everyone else combined ... and then fixing
them :-)  But I'm just one guy.

A _lot_ rides on whether, if I skip Firefox RC1, I'll still be able to get JEP
0.9.5 (or possibly JEP 0.9.5+a) into the "final" release.

And I've already found a few annoyances (one of them very easily corrected)
that could go into a JEP 0.9.5+a.

Comment 10 Steven Michaud [:smichaud] (Retired) 2005-10-24 14:55:15 PDT
Dammit!  This new bugzilla interface has now messed me up at least twice.

I didn't mean to remove the "+" blocking flag :-(

Comment 11 Josh Aas 2005-10-24 14:59:15 PDT
I think its safe to say that due to test coverage we would take 0.9.5 or nothing. Lets get 0.9.5 tested more and then land it if nothing turns up.
Comment 12 Steven Michaud [:smichaud] (Retired) 2005-10-24 15:02:33 PDT
So you're telling me that what goes into RC1 is (almost certainly) what will
go into the release version?

Comment 13 Josh Aas 2005-10-24 15:06:48 PDT
Barring something huge, yes.
Comment 14 Josh Aas 2005-10-24 17:27:26 PDT
Landed on MOZILLA_1_8_BRANCH.
Comment 15 Steven Michaud [:smichaud] (Retired) 2005-10-24 17:58:36 PDT
Thanks!
Comment 16 Scott MacGregor 2005-10-24 18:43:38 PDT
keyword pixie dust
Comment 17 Marcia Knous [:marcia - use ni] 2005-10-24 19:32:46 PDT
I am testing the tinderbox build now. The first time I entered about:plugins in the URL bar I crashed, no talkback came up. Second time launched fine. Will see if I can reproduce.
Comment 18 Marcia Knous [:marcia - use ni] 2005-10-24 19:39:49 PDT
I should add that I was testing using 10.3.9

(In reply to comment #17)
> I am testing the tinderbox build now. The first time I entered about:plugins in
> the URL bar I crashed, no talkback came up. Second time launched fine. Will see
> if I can reproduce.
> 

Comment 19 Steven Michaud [:smichaud] (Retired) 2005-10-24 20:17:52 PDT
I've tried about:plugins with JEP 0.9.5 many, many times.  In both Firefox
(my most recently tested nightly was 2005-10-22-11-mozilla1.8) and Camino.
I've never had a problem.

I don't think this crash can have been caused by the JEP.

But it'd be nice to have a crash log (not a Talkback one, but one generated by
Mac OS X, from your ~/Library/Logs/CrashReporter/ directory).


Note You need to log in before you can comment on or make changes to this bug.