Closed Bug 313527 Opened 18 years ago Closed 18 years ago

Scrolling Trackpad Function Disabled by visiting certain sites.

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 309344

People

(Reporter: yyuffy, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

When going to certain websites the scrolling trackpad function on my Apple Powerbook is disabled. The URL of one of the sites that does this is included above. The Browser tends to freeze up for a few seconds when this happens, then it restarts and the scrolling function no longer works. If however you open a new window, not tab, then then it will work in that window, but not in the old window.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.Go to the URL included.
2.
3.

Actual Results:  
The scrolling tackpad was still working

Expected Results:  
The scrolling trackpad function should have stopped.

I am using the aquatint theme, and the Flashgot extension v 0.5.9.97 is installed
If you have a recent model Apple laptop running Mac OS X 10.4, and opening a
Java applet causes you to lose trackpad-scrolling functionality in that
browser window, then your problem is a duplicate of bug 309344.

I can't find any Java applets at the page you cite.  Here's a URL that will
definitely load a Java applet:

http://java.sun.com/applets/jdk/1.4/demo/applets/Clock/example1.html

The problem with Java applets is almost certainly caused by a bug in the most
recent Apple AppleUSBTrackpad driver (version 1.1.0f6).

Please let me know if you've found a way to trigger this bug _without_ loading
a Java applet.

Indeed, I'm also having this problem on my 2005 iBook. It is very annoying since I am using this function all the time. Every time I visit a page with a even a tiny java app on it, it disables the two finger scrolling in my entire Firefox browser. 
(Firefox 1.5rc1/Mac OS X 10.4.3/iBook G4)
No feedback from Mohammed, duping.

*** This bug has been marked as a duplicate of 309344 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.