The default bug view has changed. See this FAQ.

SeaMonkey build that builds XForms won't load an XForm

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
12 years ago
8 months ago

People

(Reporter: aaronr, Assigned: Allan Beaufour)

Tracking

({fixed1.8.0.2, fixed1.8.1})

Trunk
fixed1.8.0.2, fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.24 KB, patch
Doron Rosenberg (IBM)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
If I build Seamonkey trunk and fire up Seamonkey.exe from objdbg/dist/bin, xforms does not load in when I go to an xform.  I think that the problem is that there is no longer an xforms.dll under objdbg/dist/bin/components.  Doron believes that this could also be broken in a Minimo build.
Summary: Seamonkey build that builds XForms won't load an XForm → SeaMonkey build that builds XForms won't load an XForm
(Assignee)

Comment 1

12 years ago
(In reply to comment #0)
> If I build Seamonkey trunk and fire up Seamonkey.exe from objdbg/dist/bin,
> xforms does not load in when I go to an xform.

I haven't built Seamonkey for ages... I'll check out a fresh version and see for my self.

>  I think that the problem is that there is no longer an xforms.dll under 
> objdbg/dist/bin/components.  Doron believes that this could also be broken in 
> a Minimo build.

After bug 298431 has been checked in, it does not install into dist/bin/components anymore. It installs into:
dist/bin/extensions/{cf2812dc-6a7c-4402-b639-4d277dac4c36}

Either this is not working for Seamonkey, or the application and/or version information in install.rdf is wrong.
(Assignee)

Comment 2

12 years ago
Created attachment 200748 [details] [diff] [review]
Patch

Ah, we need to wrap the XPI_NAME stuff inside ifdef MOZ_XUL_APP, because SeaMonkey expects stuff in components, and not as extensions.
Attachment #200748 - Flags: review?(doronr)

Updated

12 years ago
Attachment #200748 - Flags: review?(doronr) → review+
(Assignee)

Comment 3

12 years ago
Checked in to trunk
Status: NEW → ASSIGNED
Whiteboard: xf-to-branch
(Assignee)

Updated

12 years ago
OS: Windows XP → All
Hardware: PC → All
*** Bug 313835 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

11 years ago
checked into MOZILLA_1_8_BRANCH via bug 323691.  Leaving open for now until it gets into 1.8.0

Comment 6

11 years ago
This bug still exists in:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060205 SeaMonkey/1.0

built with:
--enable-extensions="default,xforms,schema-validation"
--enable-canvas

Pages checked:
http://www.mozilla.org/projects/xforms/samples/calc_svg_1010.xhtml
http://www.mozilla.org/projects/xforms/samples/tax_form/TaxForm.xhtml
http://www.mozilla.org/projects/xforms/samples/insurance_form/app_certificates.xhtml

Firefox 1.5 renders OK. Seamonkey 1.0 not yet.
(Assignee)

Comment 7

11 years ago
(In reply to comment #6)
> This bug still exists in:
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060205
> SeaMonkey/1.0
>
> Firefox 1.5 renders OK. Seamonkey 1.0 not yet.

That's because it is not checked in on the 1.8.0 tree yet.
(Assignee)

Comment 8

11 years ago
Checked in on 1_8_0.

Checking in Makefile.in;
/cvsroot/mozilla/extensions/xforms/Makefile.in,v  <--  Makefile.in
new revision: 1.38.2.3.2.2; previous revision: 1.38.2.3.2.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.0.2
Resolution: --- → FIXED
Whiteboard: xf-to-branch
(Reporter)

Comment 9

11 years ago
verfied fixed on MOZILLA_1_8_BRANCH
Keywords: fixed1.8.1
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.