wrong URL, should use GB2312, but it uses UTF8

RESOLVED DUPLICATE of bug 284474

Status

()

defect
RESOLVED DUPLICATE of bug 284474
14 years ago
14 years ago

People

(Reporter: jianwei_shen_123, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

open http://weather.sina.com.cn, whose character encoding is GB2312. while I click  a city's weather information in the IFRAME, such as 上海. The firefox will explains this URL as: http://cgi.news.sina.com.cn/cgi-bin/figureWeather/search.cgi?city=%E4%B8%8A%E6%B5%B7
where is UTF8 encoded. 
while the correct one should be: 
http://cgi.news.sina.com.cn/cgi-bin/figureWeather/search.cgi?city=%c9%cf%ba%a3
 where is GB2312 encoded

Reproducible: Always

Steps to Reproduce:
1.open http://weather.sina.com.cn
2.click  a city's weather information in the IFRAME
3.

Actual Results:  
the firefox resemble this url as 
http://cgi.news.sina.com.cn/cgi-bin/figureWeather/search.cgi?city=%E4%B8%8A%E6%B5%B7

Expected Results:  
the URL should be GB2312 encoded:
http://cgi.news.sina.com.cn/cgi-bin/figureWeather/search.cgi?city=%c9%cf%ba%a3
This should be fixed in a more current build (after 2005-10-10).

*** This bug has been marked as a duplicate of 284474 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.