FTP Authentication does not follow when selecting file 'Save Link As'

VERIFIED DUPLICATE of bug 315227

Status

()

defect
VERIFIED DUPLICATE of bug 315227
14 years ago
11 years ago

People

(Reporter: jere, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

When authenticated to ftp site and trying to download file with Save Link As mozilla does not remember authentication and fails to download the file. If you click file in ftp site (when authenticated) file opens fine but if you go back to index-page and click file again, firefox asks you to authenticate. 

Reproducible: Always

Steps to Reproduce:
1. Find a ftp site which requires authentication
2. Try to download a file with 'Save Link As' 


Actual Results:  
Download shows up in download manager as completed, but there's no file in the disk. 

Expected Results:  
Download starts and file ends up in your harddisk.

I'm afraid this is known bug already, but couldn't find it from bug database.
Summary: FTP Authentication does not follow when selectin file 'Save Link As' → FTP Authentication does not follow when selecting file 'Save Link As'
Not just ftp authentication, but http as well. I have a site with http authentication, and a section on it with links to files on a second site which also requires authenticaiton. Right clciking saves a file with the exact same name/extension as the link but infact is a html file with a 403 error. Ideally, firefox should prompt for password or load it from the saved passwords list.
Dupe of Bug 315227?
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 315227
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.