If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Deadline Field not available when changing several bugs at once

RESOLVED FIXED in Bugzilla 3.2

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: Alan Johnson, Assigned: Albert Ting)

Tracking

unspecified
Bugzilla 3.2
Bug Flags:
approval +

Details

Attachments

(1 attachment, 2 obsolete attachments)

1.10 KB, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

The deadline field is not available for editing when changing several fields at once. It would be nice to have available to edit for a set of bugs so that we can more easily set schedules for bugfixes.

Reproducible: Always

Steps to Reproduce:
1.Perform a search.
2.Click on "Change several bugs at once"
3.Note that there is no deadline field.

Updated

11 years ago
Assignee: query-and-buglist → create-and-change
Status: UNCONFIRMED → NEW
Component: Query/Bug List → Creating/Changing Bugs
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Updated

10 years ago
Duplicate of this bug: 399534
(Assignee)

Comment 2

10 years ago
Created attachment 285822 [details] [diff] [review]
v1

This seems like a simple patch.  Unclear how the bugzilla folks want to address the formatting issues.
Attachment #285822 - Flags: review?(LpSolit)

Comment 3

10 years ago
Comment on attachment 285822 [details] [diff] [review]
v1

>+        <label for="deadline"><b>Deadline (YYYY-MM-DD):</b></label>
>+        <input id="deadline"
>+               name="deadline"
>+               value="[% dontchange FILTER html %]"
>+               size="10" maxlength="10">

About UI: having this field at this place is strange. You should rather group remaining_time and estimated_time together, one below the other, and have deadline on the right. Either that or add a nested table and have them all 3 on the same line (not sure the UI would be nice, though).

About the code itself:
This patch doesn't work at all. If you are in the timetracking group and you don't edit this field, you get the following error:

 '--do_not_c' is not a legal date. Please use the format 'YYYY-MM-DD'.

The reason is that the field has a maxlength of 10, truncating the --do_not_change-- string and process_bug.cgi can then no longer recognize it as a magic string.
Attachment #285822 - Flags: review?(LpSolit) → review-
(Assignee)

Comment 4

10 years ago
My bad, yea, the maxlength causes a problem.  I'll delete it. 

I don't have a preference if the three fields should be on 1 line or two lines.  Unless you have an opinion, how about it looks like this:

    estimated hours                    deadline
    remaining hours

Comment 5

10 years ago
(In reply to comment #4)
>  Unless you have an opinion, how about it looks like this:
> 
>     estimated hours                    deadline
>     remaining hours

That's what I had in mind. :)
Assignee: create-and-change → altlist
(Assignee)

Comment 6

10 years ago
Created attachment 295292 [details] [diff] [review]
v2

Updated patch
Attachment #285822 - Attachment is obsolete: true
Attachment #295292 - Flags: review?(LpSolit)

Comment 7

10 years ago
Comment on attachment 295292 [details] [diff] [review]
v2

>+    <tr>
>       <th><label for="remaining_time">Remaining Hours:</label></th>
>       <td>
>         <input id="remaining_time"

Works fine and the UI is fine. But you should still add two empty cells so that the row above also has 4 cells as other columns. This can be fixed on checkin, so r=LpSolit.
Attachment #295292 - Flags: review?(LpSolit) → review+

Updated

10 years ago
Status: NEW → ASSIGNED
Flags: approval+
Target Milestone: --- → Bugzilla 3.2

Comment 8

10 years ago
Created attachment 295303 [details] [diff] [review]
patch, v2.1 (checked in)

Here is the patch I'm going to check in.
Attachment #295292 - Attachment is obsolete: true
Attachment #295303 - Flags: review+

Comment 9

10 years ago
Checking in template/en/default/list/edit-multiple.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/list/edit-multiple.html.tmpl,v  <--  edit-multiple.html.tmpl
new revision: 1.47; previous revision: 1.46
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: relnote
Resolution: --- → FIXED

Comment 10

9 years ago
Added to the release notes for Bugzilla 3.2 in a patch on bug 432331.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.