Closed Bug 313747 Opened 16 years ago Closed 14 years ago

multiple IMAP accounts disable Sent folder over IMAP

Categories

(SeaMonkey :: MailNews: Account Configuration, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 206408

People

(Reporter: tzz, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050911 Firefox/1.0.6 (Debian package 1.0.6-5)
Build Identifier: latest Mozilla for Windows

With multiple IMAP accounts, the Sent folder stops working after some time has elapsed.  It's not an immediate failure, but once it happens the "Saving to Sent folder..." dialog box will just hang until you cancel it.  The mail will be sent, but it won't be saved in the Sent folder.

This happens whether the Sent folder is on IMAP or local.  Over IMAP, I have confirmed (via a network sniffer) that nothing was sent to the IMAP server over the IMAP port.

Reproducible: Sometimes

Steps to Reproduce:
1. set up two IMAP accounts
2. set up one account to put sent messages in the Sent folder
3. use for a while...

Actual Results:  
The "Saving to Sent folder..." dialog hangs forever, it has to be cancelled.

Expected Results:  
Save to Sent folder and finish.

A network sniffer (Ethereal on the PC, and snoop on the IMAP server) showed no IMAP traffic when the Sent folder was on an IMAP account.  Only the SMTP traffic to send the message occurred.  This leads me to believe it's an internal Mozilla problem.

Removing the second IMAP account and restarting Mozilla eliminates this problem (it hasn't occurred since).
what actual version of Mozilla are you using? Have you tried Seamonkey 1.0a or a recent trunk build?
A protocol log for IMAP would be helpful.

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html
As I said, there's nothing going over the wire to the IMAP server when the problem happens.  I can't catch the problem by logging all traffic otherwise, because it takes hours to happen and it's not predictable.  If you insist, I'll do it, but it will take hours of my time for a bug that may not show up.

I'm using Mozilla 1.7.12 for Windows.

Oh, if you're using 1.7.12, never mind. There have been a lot of fixes in this area since then (1.7.x releases contain mostly security fixes from 1.7 - the vast majority of bug fixes only go into the trunk builds, e.g. SeaMonkey 1.0a)
This sounds as though it could be a duplicate of bug 206408.

*** This bug has been marked as a duplicate of 206408 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.