Closed Bug 313792 Opened 16 years ago Closed 12 years ago

File upload field (<input type="file">) has background display bug

Categories

(Core :: Layout: Form Controls, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 52500

People

(Reporter: andreasblixt, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

The file upload field border style/width, padding, font weight/etc, button is not styled. Also, some kind of bug with the background appears when width is changed (The background doesn't extend with the new width).
See attachment for details.

Reproducible: Always

Steps to Reproduce:
Style a file upload field using CSS.
Actual Results:  
Unexpected display of the file upload field.

Expected Results:  
The file upload field renders like either suggestion in the attachment.

See attachment.
Duplicate of bug 52500?
Most of this is a dup of bug 52500, but the background problem might not be.  

I can't reproduce the background problem, probably because my theme makes the button as tall as the text field.  I am using:

* Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051026 Firefox/1.5
* Firefox default theme
* Windows XP classic theme
Summary: File upload field (<input type="file">) ignores a lot of styling. Also has a minor display bug. → File upload field (<input type="file">) has background display bug
Is this still an issue?
Using: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

Looking at the test case, the file input field seems to be less styled than in previous versions of Firefox, but at least it doesn't look buggy. The only styling that seems to be used is the border. Anyways, now that the width bug doesn't seem to appear anymore, I believe this can be merged with bug 52500.
Thanks for double-checking!
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: input[type=file]
You need to log in before you can comment on or make changes to this bug.