Last Comment Bug 313839 - [ilo-PH] Ilokano: Firefox, Thunderbird
: [ilo-PH] Ilokano: Firefox, Thunderbird
Status: RESOLVED INCOMPLETE
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Localization Registration Bugs
:
Mentors:
Depends on:
Blocks: fx36-l10n-ilo
  Show dependency treegraph
 
Reported: 2005-10-25 21:23 PDT by Joseph S. Maza
Modified: 2011-06-28 12:56 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Zip file of the ilo-PH sources from Narro. (233.93 KB, application/x-zip-compressed)
2010-04-20 10:59 PDT, Joseph S. Maza
l10n: review+
Details

Description Joseph S. Maza 2005-10-25 21:23:58 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

I would like to be a contributor to the internationalization efforts for Firefox and other applications published by the Mozilla Foundation.

Name: Joseph S. Maza
Email: joemaza@comcast.net
Web Page: TBD 
Language: Ilokano (Republic of the Philippines)
Code: il-PH
Products: Firefox, Mozilla Suite, Thunderbird


Reproducible: Always
Comment 1 Axel Hecht [:Pike] 2005-10-26 01:29:37 PDT
Looking at http://www.loc.gov/standards/iso639-2/langcodes.html#ij, are we talking
about Iloko, ilo(-PH)?

Is that language spoken outside the phillipines with a sufficiently different 
dialect? You may want to have a look at 
http://wiki.mozilla.org/L10n:Simple_locale_names if we shouldn't just go for
ilo as locale name then.
Comment 2 Joseph S. Maza 2005-10-26 23:41:38 PDT
Yes, we are talking about Iloko, Philippines. I thought that it was "il-PH" when in fact it is "ilo-PH". Thanks for the correction.

Ilokano, Ilocano, Iloko, Iloco, Yloco and Samtoy are other names for the language. But, we can stick with "Iloko".
Comment 3 Joseph S. Maza 2006-10-25 19:16:09 PDT
I registered to the be localization contact for Iloko (ilo) a while back. I'm not quite sure what to do next. I had been working on an installable language pack, however, with the recent changes I will have to relocalize.

Any direction would help.
Thanks,
-- Joe
Comment 4 Gervase Markham [:gerv] 2007-09-19 02:27:29 PDT
On behalf of the Mozilla Project, I'd like to apologise for the delay in processing this request. We very much appreciate offers of help in localization.

If anyone reading this is still interested in helping to translate one or more Mozilla products into the language that this bug is about, please add a new comment to this bug to confirm your interest, saying again which products you would like to localize e.g., Firefox, Thunderbird. We will then make the necessary arrangements.
Comment 5 Joseph S. Maza 2007-09-19 17:04:28 PDT
Yes, I am still interested in localizing Firefox. I in fact had a language pack created for 1.5. But, because I got no response, I distributed to those with I was able to contact.

So, yes, I and still willing to localize. Please, point me in the direction in which to go and I will gladly follow.
Comment 6 Gervase Markham [:gerv] 2007-09-24 14:32:47 PDT
Great :-) You need to read this wiki page:
http://wiki.mozilla.org/L10n:Starting_a_localization

Create yourself a wiki page for your localisation, which registers you as the team for that language. Then, follow the instructions on the wiki to produce a language pack you can distribute through addons.mozilla.org. Once you have reached that stage, we can consider your pack for official status - although I should warn you that this is a separate process with its own complexities. Still, the community will still be able to get your pack from addons.mozilla.org in the meantime.

If you have read carefully and find the documentation isn't good enough in any way, please let us know and we will improve it.

Gerv
Comment 7 Axel Hecht [:Pike] 2007-09-25 08:57:03 PDT
Joseph, sorry for the lag.

As you have a language pack, you might find Cedric's tool to convert that to a source localization useful, find the tool and more information on http://perso.orange.fr/cedric.corazza.net/html/langpack2cvstree.html. There will be some work to be done after that, as the generation of language packs is a lossy process. But the script takes care of most of the tedious file moving work.
Comment 8 Gervase Markham [:gerv] 2008-01-30 10:03:52 PST
Joseph: how are things going? Have you been able to make any progress?

Gerv
Comment 9 Joseph S. Maza 2008-03-21 13:52:05 PDT
(In reply to comment #8)
> Joseph: how are things going? Have you been able to make any progress?
> Gerv

Thanks for the check up Gerv. As of yet, i'm still working on getting other speakers to collaborate with and create some other tool than MT to translate the text.
Thanks again.
Comment 10 Seth Bindernagel 2008-08-26 21:00:49 PDT
Hello Joseph:

Thank you for all of your work toward localizing Firefox.  We're at the unique point of determining if you should localize for Firefox 3 or move onto localizing for Firefox 3.1, depending on your availability and interest.

If you are interested in working on *something* that is stable, you can continue to focus on localizing Firefox 3.  We can get stable builds going for you.  However, we will eventually ship your work in Firefox 3.1 and you will need to update the effort you are putting into Firefox 3 right now.  The good news is that the string changes from Fx 3 --> Fx 3.1 are presently small in number (~30), so the update should not be too much too handle.  

However, if you are interested in moving your effort toward localizing Firefox 3.1, then you can read the following documentation on working with Mercurial and getting a local environment set up on your machine.

http://developer.mozilla.org/en/L10n_on_Mercurial

or learn the basics about Mercurial here:

http://developer.mozilla.org/en/Mercurial

Thanks so much for your hard work.  As always, ping us with any questions, we are ready to help.

Kind regards,
Sethb
Comment 11 Axel Hecht [:Pike] 2009-05-12 08:29:01 PDT
I haven't seen activity here in a while, thus I'm resolving this INCOMPLETE.

If there is activity again, please feel free to reopen or file a new bug. Thanks.
Comment 12 Joseph S. Maza 2009-11-11 06:51:48 PST
OK. A while back this was marked incomplete. 

I'm starting this up again and reached about 60% when I left off. What are the next steps?

Thanks,
-- Joe
Comment 13 Seth Bindernagel 2009-11-11 10:05:59 PST
(In reply to comment #12)
> OK. A while back this was marked incomplete. 
> 
> I'm starting this up again and reached about 60% when I left off. What are the
> next steps?

Joe, can you send me your complete translation?  You can zip the files together and attach it to this bug.  That would be the best next step.
Comment 14 Joseph S. Maza 2009-11-12 09:49:59 PST
So, far I have about 60-70% done. I'm revising the localizations. Can I attach what has been translated thus far?

Thanks,
-- Joe
Comment 15 Seth Bindernagel 2009-11-12 12:10:38 PST
(In reply to comment #14)
> So, far I have about 60-70% done. I'm revising the localizations. Can I attach
> what has been translated thus far?

Well, you're welcome to do that, but we really need to see the final product.  If attaching it allows others who might use ilo-PH to see your progress and you can recruit community members to help you, then go for it!  :)
Comment 16 Joseph S. Maza 2009-11-13 04:57:16 PST
That seems to have been a major stumbling block with both Iloko and Tagalog: getting interest going. I've received some translated strings, but after a while some of the translators respond that they get a headache since much of the computer jargon hasn't been translated, at least in Iloko.

I've been compiling translations of common phrases and words, but getting consensus from the Iloko speaking community is like pulling teeth.  I forgot when the next deadlines are, but in the meantime I'll review as much as I can of what has been translated before attaching the archive.


-- Joe
Comment 17 Seth Bindernagel 2009-11-13 08:35:55 PST
(In reply to comment #16)
> That seems to have been a major stumbling block with both Iloko and Tagalog:
> getting interest going. I've received some translated strings, but after a
> while some of the translators respond that they get a headache since much of
> the computer jargon hasn't been translated, at least in Iloko.
> 
> I've been compiling translations of common phrases and words, but getting
> consensus from the Iloko speaking community is like pulling teeth.  I forgot
> when the next deadlines are, but in the meantime I'll review as much as I can
> of what has been translated before attaching the archive.

OK, please keep us informed as you make progress and finish.
Comment 18 Joseph S. Maza 2009-11-21 19:20:37 PST
(In reply to comment #17)
> (In reply to comment #16)
> > That seems to have been a major stumbling block with both Iloko and Tagalog:
> > getting interest going. I've received some translated strings, but after a
> > while some of the translators respond that they get a headache since much of
> > the computer jargon hasn't been translated, at least in Iloko.
> > 
> > I've been compiling translations of common phrases and words, but getting
> > consensus from the Iloko speaking community is like pulling teeth.  I forgot
> > when the next deadlines are, but in the meantime I'll review as much as I can
> > of what has been translated before attaching the archive.
> OK, please keep us informed as you make progress and finish.

I've "finished" the Iloko translation barring any linguistic checks and other checks.

I've been using Narro for some of the translation work. It has a facility to create a zip file, but I don't know if the layout in the file is what you need/want. If that is the format that will work I can attach one or send one before the end of the next week.

Just let me know how you'd like the files and I should be able to get them to you.
Comment 19 Seth Bindernagel 2009-11-22 11:23:56 PST
(In reply to comment #18)
> I've been using Narro for some of the translation work. It has a facility to
> create a zip file, but I don't know if the layout in the file is what you
> need/want. If that is the format that will work I can attach one or send one
> before the end of the next week.


Please do that.
Comment 20 Seth Bindernagel 2010-04-08 10:53:40 PDT
Any update on your Iloko language pack?  Looks like it is 99% finished in Narro.  It doesn't matter if it is 100% complete, but we just want to see something.  Can you attach the .xpi export from Narro?
Comment 21 Seth Bindernagel 2010-04-13 09:24:55 PDT
Ping.
Comment 22 Seth Bindernagel 2010-04-13 09:37:17 PDT
Or, better yet, if you have the source files for your locale, please attach those.  That would be best and what we need anyway.  :)  If our memory serves us correctly, you should be able to export source code from Narro.  Please attach that when ready.
Comment 23 Joseph S. Maza 2010-04-20 10:59:19 PDT
Created attachment 440274 [details]
Zip file of the ilo-PH sources from Narro.

Zip file of the ilo-PH sources from Narro.
Comment 24 Joseph S. Maza 2010-04-20 11:00:14 PDT
I've attached a Zip file that was exported from Narro, per your request. Sorry, for the delay. Roommate took the Internet with him when he moved.
Comment 25 Axel Hecht [:Pike] 2010-04-20 11:12:32 PDT
I imagine that internets takeaway literally :-)

Review comments coming up later.
Comment 26 Axel Hecht [:Pike] 2010-04-20 11:32:34 PDT
Joseph, one thing in the middle, we're usually keen to use locale codes as short as feasible, and it seems that the region code -PH doesn't add any specifity to ilo. Could we go with just 'ilo'?
Comment 27 Joseph S. Maza 2010-04-20 13:15:10 PDT
ilo is just fine with me
Comment 28 Axel Hecht [:Pike] 2010-04-27 10:01:44 PDT
Comment on attachment 440274 [details]
Zip file of the ilo-PH sources from Narro.

r=me, this looks fine.

I'm filing a flock of bugs now that you'll get bugmail for, and then I'll close out this bug, with a bunch of detail.
Comment 29 Axel Hecht [:Pike] 2011-05-26 05:12:09 PDT
We haven't seen any feedback on the Iloko effort for about a year now.

Is there still interest? Or are there new people that'd be interested in taking an Iloko localization through the new release process?
Comment 30 Axel Hecht [:Pike] 2011-06-11 11:49:28 PDT
Sadly, we've failed to get this effort up and going in full.

When there's a new team coming up, or this team revives, please get in contact on mozilla.dev.l10n.new-locales.
Comment 31 Joseph S. Maza 2011-06-28 12:56:48 PDT
Hi Axel,

These emails have fallen off my radar. They were going into a folder on my mail server that my mail client didn't pick up.

Speaking of picking up, how can this be revived? 

I've been working on the new strings in Narro and I've reviewed as much of the old strings and I have been able since I've been the one-person team.

Note You need to log in before you can comment on or make changes to this bug.