Flash player 8 international character encoding of input text fields

RESOLVED DUPLICATE of bug 347185

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 347185
12 years ago
9 years ago

People

(Reporter: cesperanc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

I'm a webdeveloper and I have a problem with the firefox flash plugin. The problem is that when I try to write portuguese text in input text fields inside a swf file that's playing with firefox and his flash plugin, the text isn't rendered properly. When I write accented characters (very common in portuguese language) inside flash text fields this chars appears wrong nominated. An example: the char á (represented in html by á) appears like ºa; The char @ appears like 2; ã (represented in html by ã) appears like ¿a. In a string like Olá (witch means hi or hello) it appears like Olºa. A string like céu (witch means sky) it is rendered like cºeu.

I'm using a laptop keybord with portuguese keyboard layout.

This problem occurs with flash 8 and 7 plugin. I have tested with many versions of firefox. The last one's had been:
->Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006
Firefox/1.4.1
->Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12) Gecko/20050919
Firefox/1.0.7) and previous versions.

In Internet Explorer it works smoothly. The problem occurs in every flash files (swf) that have input text fields inside the firefox


Reproducible: Always

Steps to Reproduce:
1.open a page that have a flash file runing on it, with a text field
2.try to write something in correct portuguese

Actual Results:  
the text isn't rendered properly

Expected Results:  
that the text is rendered properly with accented characters.

laptop keyboard with portuguese layout

Comment 1

12 years ago
IE and FF use different plugin technology (ActiveX in IE, standard Netscape-type in FF).  So this is probably a Flash bug, which you won't see in IE. 

Comment 2

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12)
> Gecko/20050919 Firefox/1.0.7
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12)
> Gecko/20050919 Firefox/1.0.7
> 
> I'm a webdeveloper and I have a problem with the firefox flash plugin. The
> problem is that when I try to write portuguese text in input text fields inside
> a swf file that's playing with firefox and his flash plugin, the text isn't
> rendered properly. When I write accented characters (very common in portuguese
> language) inside flash text fields this chars appears wrong nominated. An
> example: the char á (represented in html by á) appears like ºa; The char
> @ appears like 2; ã (represented in html by ã) appears like ¿a. In a
> string like Olá (witch means hi or hello) it appears like Olºa. A string like
> céu (witch means sky) it is rendered like cºeu.
> 
> I'm using a laptop keybord with portuguese keyboard layout.
> 
> This problem occurs with flash 8 and 7 plugin. I have tested with many versions
> of firefox. The last one's had been:
> ->Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006
> Firefox/1.4.1
> ->Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12) Gecko/20050919
> Firefox/1.0.7) and previous versions.
> 
> In Internet Explorer it works smoothly. The problem occurs in every flash files
> (swf) that have input text fields inside the firefox
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.open a page that have a flash file runing on it, with a text field
> 2.try to write something in correct portuguese
> 
> Actual Results:  
> the text isn't rendered properly
> 
> Expected Results:  
> that the text is rendered properly with accented characters.
> 
> laptop keyboard with portuguese layout
> 

I opened a phisher site and pasted a 2 Meg line into the password box.  Foxfire no longer accepts any input without ceasing to respond!  Other browsers still work.  I uninstalled and re-installed and it still only displays the first character of input, then locks up.(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12)
> Gecko/20050919 Firefox/1.0.7
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12)
> Gecko/20050919 Firefox/1.0.7
> 
> I'm a webdeveloper and I have a problem with the firefox flash plugin. The
> problem is that when I try to write portuguese text in input text fields inside
> a swf file that's playing with firefox and his flash plugin, the text isn't
> rendered properly. When I write accented characters (very common in portuguese
> language) inside flash text fields this chars appears wrong nominated. An
> example: the char á (represented in html by á) appears like ºa; The char
> @ appears like 2; ã (represented in html by ã) appears like ¿a. In a
> string like Olá (witch means hi or hello) it appears like Olºa. A string like
> céu (witch means sky) it is rendered like cºeu.
> 
> I'm using a laptop keybord with portuguese keyboard layout.
> 
> This problem occurs with flash 8 and 7 plugin. I have tested with many versions
> of firefox. The last one's had been:
> ->Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006
> Firefox/1.4.1
> ->Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12) Gecko/20050919
> Firefox/1.0.7) and previous versions.
> 
> In Internet Explorer it works smoothly. The problem occurs in every flash files
> (swf) that have input text fields inside the firefox
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.open a page that have a flash file runing on it, with a text field
> 2.try to write something in correct portuguese
> 
> Actual Results:  
> the text isn't rendered properly
> 
> Expected Results:  
> that the text is rendered properly with accented characters.
> 
> laptop keyboard with portuguese layout
> 

Comment 3

10 years ago
We're experiencing the same problem here in Finland. When wmode is set to opaque or transparent, keyboard input-map (or charset) is kind of us-ascii with some scandic characters like ä and ö. 

So, when i press SHIFT and go throught numbers i should get
1: !
2: "
3: #
4: ¤
5: %
6: &
7: /
8: (
9: )
0: =

But, when wmode is set to opaque or transparent, I get: 
1: !
2: @ 
3: #
4: $
5: %
6: ^
7: &
8: *
9: (
0: )

When I set wmode=window, everything works as it should. Also, I dont get this problem with IE.

Also, I should get these chars by pressing ALT-GR and numbers
2: @
3: £
4: $
5: €
7: {
8: [
9: ]
0: }

but I get only numbers from 0-9.

You can set Finnish keyboard mapping from "Regional and language options" under control panel. Select languages -> details. Add Finnish / Finnish.

I cant use wmode=window because popup windows get blocked by firefox if i'm using the latest flash, 9.0.115.0 and latest firefox 2.0.0.11.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 347185
You need to log in before you can comment on or make changes to this bug.