"Address Book" bookmark group doesn't stay in synch with Mac OS X Address Book

RESOLVED FIXED in Camino1.0

Status

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: rahji, Assigned: mikepinkerton)

Tracking

unspecified
Camino1.0
PowerPC
Mac OS X
Bug Flags:
camino1.0 +

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050914 Camino/1.0a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050914 Camino/1.0a1

The "Address Book" group that is listed when "Show All Bookmarks" is displayed is apparently imported from the Mac OS X Address Book.  It looks like it is only imported once, however, and not updated.  There also doesn't appear to be a way to "refresh" the group to get it back in sync with Address Book.  Basically, if you change a contact's URL in Address Book, the old URL still appears in Camino with no way to change it.  Even clicking "Get Info" on that bookmark doesn't allow you to change the URL since that field is read-only.  I love this feature otherwise, by the way.


Reproducible: Always

Steps to Reproduce:
1. Find an exiting bookmark in the "Address Book" group
2. Go to Mac OS X Address Book and change that contact's URL
3. Go back to "Show all Bookmarks" in Camino and find that contact

Actual Results:  
The URL for that contact is the same as it was before doing the above steps.

Expected Results:  
The Address Book group should be refreshed from the contents of the actual Address Book app.  This could happen on a scheduled basis (maybe only if Address Book is open already to avoid the overhead of opening it?). It could happen on each startup of Camino.  There could be a Refresh button or contextual menu item for this bookmark group.  Or a Refresh contextual menu item for that specific contact.  At the least, the URL field in the Get Info window for that bookmark would not be read-only (that's the least desirable choice obviously because it doesn't help "synchronize" with Address Book)
WFM Camino 2005102504 (v1.0a1+), 10.3.9.

It does it live (or at least between the time I switch from the Address Book to Camino's open Address Book collection.

Comment 2

13 years ago
I can reproduce this with Camino 2005102004 (1.0a1+), 10.4.2

Doesn't even update after relaunching Camino.
(Assignee)

Comment 3

13 years ago
i can repro this. 10.4-only it seems. go apple.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: camino1.0+
Target Milestone: --- → Camino1.0
(Assignee)

Comment 4

13 years ago
apple depricated the homepage property we were using in tiger. fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

13 years ago
i did one more tweak on this (looking for the tiger property first, then the depricated one) so give this one more spin before reopening if it doesn't work.

Comment 6

13 years ago
The change made on line 48 broke building for me, although it's entirely likely I've got something screwed up elsewhere. I pulled a fresh CVS this afternoon, did a distclean, etc. No dice yet. (10.4.3, Xcode 2.1)

cl
You need to log in before you can comment on or make changes to this bug.