Last Comment Bug 314015 - nsComponentManagerUtils.h uses wrong linking macro, SDK 1.8 is broken
: nsComponentManagerUtils.h uses wrong linking macro, SDK 1.8 is broken
Status: VERIFIED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg]
:
Mentors:
: 292259 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 05:38 PDT by Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg]
Modified: 2005-11-10 18:36 PST (History)
5 users (show)
benjamin: blocking1.8rc2+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix usage (3.55 KB, patch)
2005-10-27 05:45 PDT, Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg]
darin.moz: review+
asa: approval1.8rc2+
Details | Diff | Splinter Review

Description Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2005-10-27 05:38:59 PDT
nsComponentManagerUtils.h uses NS_COM in places where it should use NS_COM_GLUE, meaning that usage of do_CreateInstanceByContractID is broken for the 1.8 SDK.
Comment 1 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2005-10-27 05:45:26 PDT
Created attachment 200983 [details] [diff] [review]
Fix usage
Comment 2 Darin Fisher 2005-10-27 11:58:46 PDT
Comment on attachment 200983 [details] [diff] [review]
Fix usage

wow, that's very unfortunate.  the ff 1.5 train has already nearly left the station too :(
Comment 3 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2005-10-27 12:04:06 PDT
Fixed on trunk.
Comment 4 Darin Fisher 2005-10-27 12:05:22 PDT
This bug makes me wonder if we shouldn't have a separate release branch for the GECKO_1_8_SDK.
Comment 5 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2005-10-27 12:08:53 PDT
Let's not go down the private-branch road yet, I'm pretty sure this can land before RC2.
Comment 6 Darin Fisher 2005-10-27 13:02:05 PDT
What RC2? ;-)
Comment 7 Andrew Schultz 2005-10-27 22:26:34 PDT
with this change, rdf/tests/triplescat fails to compile (see Brad tbox):

/usr/bin/ld: triplescat.o(.text+0x203): unresolvable R_386_GOTOFF relocation against symbol `vtable for nsCreateInstanceByContractID'
/usr/bin/ld: final link failed: Nonrepresentable section on output
Comment 8 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2005-10-28 06:25:30 PDT
triplescat did not have MOZILLA_INTERNAL_API, now fixed r=Pike

Fix verified by original reporter on npm.xpcom
Comment 9 timeless 2005-10-30 08:49:39 PST
i think i filed a bug about this elsewhere, could someone find it? :(
Comment 10 Christian :Biesinger (don't email me, ping me on IRC) 2005-10-30 09:03:14 PST
timeless: bug 292259 perhaps?
Comment 11 Asa Dotzler [:asa] 2005-10-31 14:48:30 PST
moving out to the 1.8 rc2 ride-along candidate list. We'll consider taking this if we do an RC2.
Comment 12 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2005-11-01 05:59:45 PST
Fixed on 1.8 branch.
Comment 13 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-11-10 18:36:48 PST
*** Bug 292259 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.