Crash when entering criteria in View box in the Search Bar with mail.compose.max_recycled_windows set to non-zero value

RESOLVED INVALID

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Lewis Rosenthal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9a1) Gecko/20051021 SeaMonkey/1.1a Mnenhy/0.7.2.0
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9a1) Gecko/20051021 SeaMonkey/1.1a Mnenhy/0.7.2.0

After setting mail.compose.max_recycled_windows to 1 in prefs.js (see Bug #104989 for details and history of this pref), subsequent composition windows open more quickly and MailNews appears to perform well. However, upon entering any text in the View box in the Search Bar (see View | Show/Hide | Search Bar), Mozilla crashes (exits without notice), leaving the following in POPUPLOG.OS2:

10-26-2005  17:11:38  SYS3175  PID 0096  TID 0001  Slot 00d6
J:\MOZILLA.ORG\SEAMONKEY\SEAMONKEY.EXE
c0000005
1535eb54
P1=00000001  P2=00000034  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=014879a0  EBX=00000034  ECX=00000000  EDX=01487918
ESI=00000034  EDI=00000002  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1535eb54  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0011fc60  SSACC=f0f3  SSLIM=ffffffff
EBP=0011fc68  FLG=00012216

MAILNEWS.DLL 0001:0006eb54

Note that the symptom occurs after the second or third time entering text in the View box, not upon the first entry of criteria.

Reproducible: Always

Steps to Reproduce:
1. Close Mozilla.
2. Set mail.compose.max_recycled_windows to 1 in prefs.js; save the file.
3. Start Mozilla MailNews.
4. Enter something in the View box in the Search Bar.
5. Clear the search criteria.
5. Enter something else in the View box in the Search Bar.

Actual Results:  
Mozilla exits abruptly, apparently crashing in MAILNEWS.DLL.

Expected Results:  
Mozilla should not crash.

Bug occurs with default theme (though the first time this happened was with Sky Pilot Classic). Resetting mail.compose.max_recycled_windows to the default value of 0 has resulted in this issue not reappearing, even after entering several different criteria in the View box at various times and over long sessions.

Workaround is to not use mail.compose.max_recycled_windows to increase the performance of redrawing the composition window.

Comment 1

13 years ago
I tried this lots of times and it always worked fine with

Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9a1) Gecko/20051113 SeaMonkey/1.5a Mnenhy/0.7.2.10017
and
Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8) Gecko/20051112 SeaMonkey/1.0b Mnenhy/0.7.2.10017

Maybe your old mnenhy version is the cause, it's known to be problematic on the current trunk.
Version: unspecified → Trunk
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Maybe your old mnenhy version is the cause, it's known to be problematic on the
> current trunk.
> 
Thanks, Peter. I've since upgraded Mnenhy to 0.7.2.10015 (per your suggestion on the ng), and I'll give this pref another try now. I'll submit a follow-up report, and close the bug at that time, if things appear stable for a couple days. If the problem appears again, I'll ask Karsten for the 0.7.2.10017 nightly you are using (or uninstall Mnenhy) and test again.

Lewis
(Reporter)

Comment 3

13 years ago
This does indeed appear to have been a XUL cache issue. I can no longer reproduce. Marking as Resolved/Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.