Last Comment Bug 314137 - Custom search plugins are deleted upon installation/upgrade.
: Custom search plugins are deleted upon installation/upgrade.
Status: RESOLVED DUPLICATE of bug 311626
:
Product: Firefox
Classification: Client Software
Component: Search (show other bugs)
: unspecified
: x86 Windows 2000
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 21:04 PDT by Mateo
Modified: 2005-10-28 15:36 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mateo 2005-10-27 21:04:35 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Previouss custom search engines are deleted when installing Firefox 1.5 RC test build.
I had many search plugins installed, I even had many custom made ones for my own personal use that took many hours to create.
When I upgraded installing 1.5RC all search engines were removed and replaced by the 1.5 default ones. They are not even backed up!

- Custom search engines should not be removed, just as bookmarks should not be removed.
- It would be ok to add or update to existing search plugins, but never remove them.

Reproducible: Didn't try

Steps to Reproduce:
Comment 1 Dave Townsend [:mossop] 2005-10-28 02:09:36 PDT
In firefox 1.5 search plugins are installed into the user profile so updating will not overwrite them. Unfortunatly the update from 1.0.x to 1.5 will overwrite the search plugins.


*** This bug has been marked as a duplicate of 123315 ***
Comment 2 Mateo 2005-10-28 14:51:01 PDT
I think it's great that search plugins be keept from 1.5 on in the user profile... sounds ideal.
But removing current ones during update from 1.0.x to 1.5 is a terrible thing to do, a huge mistake.

They should either be backed up somewhere, keept for all users, or moved to existing user profiles.
Comment 3 Mateo 2005-10-28 15:32:14 PDT
I've been reading bug 123315
I dont see how this is a duplicate of it.
It is a bug, regresion caused by the fix in 123315, but not a duplicate of it.

 - 123315 is about the need to move search plugins to profile, and I think that's great.

 - This here is about a bug in how it was implemented: Custom search plugins are DELETED while till now they were always keep. (REGRESSION).


Its a bug caused by the fix in 123315, but not the same bug.
I dont think this should be marked as resolved duplicate and if fact should be a 1.5 blocker.
Comment 4 Dave Townsend [:mossop] 2005-10-28 15:36:01 PDT

*** This bug has been marked as a duplicate of 311626 ***

Note You need to log in before you can comment on or make changes to this bug.