Last Comment Bug 314158 - select(1) fails to bind item labels correctly
: select(1) fails to bind item labels correctly
Status: RESOLVED FIXED
: fixed1.8.0.2, fixed1.8.1
Product: Core
Classification: Components
Component: XForms (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Doron Rosenberg (IBM)
: Stephen Pride
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 01:46 PDT by aaronr
Modified: 2006-07-07 10:04 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (1.97 KB, application/xhtml+xml)
2005-10-28 01:48 PDT, aaronr
no flags Details
better testcase - both itemset/repeat are affected (2.20 KB, application/xhtml+xml)
2005-11-01 12:36 PST, Doron Rosenberg (IBM)
no flags Details
fix itemset/repeat (2.85 KB, patch)
2005-11-01 12:38 PST, Doron Rosenberg (IBM)
bugs: review+
aaronr: review+
Details | Diff | Review

Description aaronr 2005-10-28 01:46:02 PDT
I noticed that after I wrote this testcase for select and select1 that the labels didn't show up and that it gave off warnings in nsXFormsUtils::GetNodeValue.  It looks like that instead of the labels binding to the description node, they bind to the document and are returning a nodeType of nsIDOMNode::DOCUMENT_NODE which we don't expect.

Testcase coming.
Comment 1 aaronr 2005-10-28 01:48:03 PDT
Created attachment 201106 [details]
testcase

Should see a select1 with Vanilla, Strawberry and Chocolate as items.
Comment 2 Doron Rosenberg (IBM) 2005-11-01 12:36:37 PST
Created attachment 201548 [details]
better testcase - both itemset/repeat are affected
Comment 3 Doron Rosenberg (IBM) 2005-11-01 12:38:13 PST
Created attachment 201549 [details] [diff] [review]
fix itemset/repeat

Issue is simple - itemset/repeat were passing in a domElement to ->SetContext.  However, a attribute node is not a dom element, and thus the QI from dom node to dom element failed.
Comment 4 Doron Rosenberg (IBM) 2005-11-01 14:48:18 PST
checked into trunk
Comment 5 aaronr 2006-02-02 17:18:10 PST
checked into MOZILLA_1_8_BRANCH via bug 323691.  Leaving open for now until it gets into 1.8.0
Comment 6 aaronr 2006-07-07 10:04:22 PDT
verfied fixed on MOZILLA_1_8_BRANCH

Note You need to log in before you can comment on or make changes to this bug.