Closed Bug 314291 Opened 14 years ago Closed 14 years ago

Unifinder is really slow

Categories

(Calendar :: Sunbird Only, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jminta, Assigned: mostafah)

References

Details

Attachments

(1 file)

The unifinder becomes really slow once the number of events in the calendar becomes large.  (I'm currently testing a file of ~1,200 events.)  I have a couple of patches/ideas that will allow us to improve here.
that wouldn't be my file, by any chance? :)
Much like the tasks patch I attached earlier today.  This will remove a ton of calls to getItems and should make adding/modifying/deleting items a lot faster, especially for big calendars.
Attachment #218441 - Flags: first-review?(mvl)
Comment on attachment 218441 [details] [diff] [review]
use better tree methods

r=mvl
Attachment #218441 - Flags: first-review?(mvl) → first-review+
*** Bug 335427 has been marked as a duplicate of this bug. ***
Whiteboard: [needs landing]
Checked in on trunk and MOZILLA_1_8_BRANCH
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Whiteboard: [needs landing]
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060827 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.