DOM inspector right view don't always refresh after new URL examination

RESOLVED DUPLICATE of bug 193942

Status

Other Applications
DOM Inspector
RESOLVED DUPLICATE of bug 193942
13 years ago
7 years ago

People

(Reporter: Sébastien Mouren, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

I am examining a file through the DOM inspector; When I update the inspection to a new URL, the right view for DOM nodes and/or Javascript object doesn't, under specific circumstances, refresh to a new object/DOM node examinated. I can only have access to the previously examinated node or object.

Reproducible: Always

Steps to Reproduce:
1.Open up DOM inspector,
2.Enter an URL and press inspect,
3.Change the left inspector view to Javascript object,
4.Change the right view to Javascript object and observe the Document.URL property,
5.Revert to Document - DOM nodes in the left inspector view,
6.Type in a new URL in the adress bar and press Inspect.

Actual Results:  
The Javascript property Document.URL for the newly loaded document isn't refreshed in the right view.

Expected Results:  
The Document.URL should reflect the URL string of the newly loaded document.

Could be reproduced here:
initial URL: http://www.aspras.com/43.html
seond URL: http://www.aspras.com/44.php

Comment 1

13 years ago
note to self: confirm this bug (reporter: based on your steps, and my understanding of domi, i believe that this bug is real, but i don't have time atm to verify it's not a duplicate and confirm it - sorry)
I can't reproduce, but I also could not find a document.URL property.  The closest I got was document.baseURI, but upon changing the location it did in fact update.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060715 Minefield/3.0a1
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
Sounds like bug 193942.  There are actually a much wider range of conditions and symptoms.  This is entirely due to the fact that the JS Object viewer doesn't dispatch a selection change event, so the object panel will never update when the document panel is showing the JS Object viewer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 193942
You need to log in before you can comment on or make changes to this bug.