trying to get a forward mail rule to fire from a POP3 account [@ msg_pick_real_name]

RESOLVED DUPLICATE of bug 315091

Status

MailNews Core
Composition
--
critical
RESOLVED DUPLICATE of bug 315091
12 years ago
10 years ago

People

(Reporter: timeless, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
Incident ID: 11202907
Stack Signature	msg_pick_real_name a59f7672
Product ID	ThunderbirdTrunk
Build ID	2005102707
Trigger Time	2005-10-28 19:41:24.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	thunderbird.exe + (004bb055)
URL visited	
User Comments	Testing bug 301808 - trying to get a forward mail rule to fire from a POP3 account
Since Last Crash	2013 sec
Total Uptime	2013 sec
Trigger Reason	Access violation
Source File, Line No.	e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/compose/src/nsMsgCompUtils.cpp, line 1667
Stack Trace 	
msg_pick_real_name  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/compose/src/nsMsgCompUtils.cpp, line 1667]
nsMsgComposeAndSend::AddCompFieldRemoteAttachments  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/compose/src/nsMsgSend.cpp, line 2469]
nsMsgComposeAndSend::HackAttachments  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/compose/src/nsMsgSend.cpp, line 2642]
nsMsgComposeAndSend::Init  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/compose/src/nsMsgSend.cpp, line 3311]
nsMsgComposeAndSend::CreateAndSendMessage  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/compose/src/nsMsgSend.cpp, line 4156]
nsMsgCompose::_SendMsg  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/compose/src/nsMsgCompose.cpp, line 945]
nsMsgCompose::SendMsg  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/compose/src/nsMsgCompose.cpp, line 1125]
nsMsgComposeService::ForwardMessage  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/compose/src/nsMsgComposeService.cpp, line 1181]
nsParseNewMailState::ApplyForwardAndReplyFilter  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/local/src/nsParseMailbox.cpp, line 2007]
nsPop3Sink::IncorporateComplete  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/local/src/nsPop3Sink.cpp, line 883]
nsPop3Protocol::HandleLine  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/local/src/nsPop3Protocol.cpp, line 3393]
nsPop3Protocol::RetrResponse  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/local/src/nsPop3Protocol.cpp, line 3170]
nsPop3Protocol::ProcessProtocolState  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/local/src/nsPop3Protocol.cpp, line 3798]
nsMsgProtocol::OnDataAvailable  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mailnews/base/util/nsMsgProtocol.cpp, line 350]
nsInputStreamPump::OnStateTransfer  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 437]
nsInputStreamPump::OnInputStreamReady  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 341]
nsInputStreamReadyEvent::EventHandler  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/xpcom/io/nsStreamUtils.cpp, line 216]
SETUPAPI.DLL + 0x30c24 (0x778b0c24)

Comment 1

12 years ago
i confirm the bug
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB11486948E
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB11635674H
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB11636801E

Our webmail was not available and our pop account only accessible via vpn, so i had set a filter to forward automatically all mails from my pop account to a gmail adress to be able to read my mails in an other country.

After 1 day, thunderbird crashed ... (see TB11486948E) after forwarding 35 mails). --> restart and go to england
Now, as i come back 3 days after, TB was like a zombie (check mails didn't works and as i quit tb, the process is stayed in memory ...
kill the process, launch tb, check mail --> crash (TB11635674H)
Relaunch TB --> no crash but i cannot check mail with TB --> i have to quit and restart  

--> Try to download 1 mail on 353 on the server --> the waiting  sand glass icon
appairs after downloading mail 1/353 and TB is not working correctly
--> quit, have to delete the process and restarting
--> crash after relaunching TB11636801E
--> restarting
--> disabling the filter
--> it works

Comment 2

12 years ago
as this is a feature of TB 1.5 ... but the feature is broken, maybe this feature should be disabled before the release of 1.5 if it can't be fixed for the release ...
For me, this is a major blocker

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 315091 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
(Assignee)

Updated

7 years ago
Crash Signature: [@ msg_pick_real_name]
You need to log in before you can comment on or make changes to this bug.