If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash (see Talkback event TB11273741W)

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051030 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051030 Firefox/1.5

crash, see Talkback event TB11273741W

see also windbg log, http://users.skynet.be/antoine.mechelynck/other/windbg.log

Reproducible: Didn't try

Steps to Reproduce:

Actual Results:  
crash

Expected Results:  
no crash

as soon as I get out of this bug-creation form and into the "standard" Bugzilla bug listing I'll post the debug listing as an attachment.
Created attachment 201401 [details]
crash analysis using windbg

Attachment obtained as follows:

1. Firefox crashes. DrWatson and Talkback come up.
2. Send Talkback report, don't close DrWatson.
3. Start windbg.exe
4. File -> Attach to Process
5. scroll down to Firefox
6. OK
7. (Workspace?) Yes
8. View -> Command
9. .symfix+
10. .reload
11. !analyze -v
12. Close windbg, send DrWatson report to Microsoft.
From Talkback report: stack signature  firefox.exe + 0x21c71 (0x00421c71) 4c999cec

The Talkback listing shows a longish stack trace across several filenames, with numerical addresses and no symbols.

Comment 3

12 years ago
if you get:
BUCKET_ID:  MANUAL_BREAKIN

from windbg's !analyze -v, repeat it w/ !analyze -v -f, but in this case there's no symbols from firefox and the talkback stack shows it's all firefox, windbg probably won't help...

Comment 4

12 years ago
Unfortunately, I can't tell what the problem is because I can't reproduce the crash and I don't have a stack trace with function names.

If you're able to reproduce the crash, can you try with a few different builds?  Maybe Talkback will work better with other builds.
Keywords: crash
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051030 Firefox/1.5 ID:2005103021

WFM.
(In reply to comment #3)
> if you get:
> BUCKET_ID:  MANUAL_BREAKIN
> 
> from windbg's !analyze -v, repeat it w/ !analyze -v -f, but in this case
> there's no symbols from firefox and the talkback stack shows it's all firefox,
> windbg probably won't help...
> 

well, thanks for the info. I'll try to remember it next time (though of course, the longer till next time the better ;-) ).

(In reply to comment #4)
Sorry, I don't know how to reproduce the crash. AFAICT I was doing nothing (waiting for the mouse cursor to be a pointer, not an hourglass) and Firefox crashed on me.

What kind of builds do you recommend? Currently I'm using Firefox 1.5 nightlies published as ftp://mozilla.osuosl.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/firefox-1.5.en-us.win32.installer.exe


Best regards,
Tony.
(In reply to comment #5)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051030
> Firefox/1.5 ID:2005103021
> 
> WFM.
> 

Hm. I was (and still am) using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051030 Firefox/1.5 ID:2005103002 -- maybe the fact that 67 tabs were open and that Windows was heavily using its virtual memory (see for instance "memory use" bugs like bug 130157, bug 174604, bug 268138 etc.) were relevant. I'm not (yet) seeing any newer nightly build than this one.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051101 Firefox/1.6a1

WFM
I guess it's time to close this bug. The Talkback trace is gone, I have moved from Windows to Linux without having seen this particular crash reappear, and apart from the single incident all I see is WFM comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.