cyrillic characters in mailto: command are not processed correctly when external windows mail client is used

RESOLVED DUPLICATE of bug 227268

Status

RESOLVED DUPLICATE of bug 227268
13 years ago
13 years ago

People

(Reporter: lvm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a

Windows XP SP2 box with Outlook 2003 SP1 (not outlook express!) used as a mail client - exchange server and all that. External mail handler is enabled in mozilla by setting network.protocol-handler.external.mailto config string to yes. Clicking on mailto: link in mozilla creates a new outlook message but all cyrillic characters in mailto: string are garbled. Looks like mailto: string is passed to external mail handler in UTF-8 encoding while outlook expects a single-byte string in default system codepage (set to 1251) - cyrillic capital A (0xc0 in codepage 1251) is replaced with 0xd090 and so on. Both Opera and Internet Explorer do not have this problem. 

Bug 305745 suggests always using UTF-8 for mailto: and although it is still NEW, this is exactly what happens and should not happen in my configuration. Maybe an option should be added control use of unicode or single-byte encoding for mailto.




Reproducible: Always

Steps to Reproduce:
1. click on mailto: link with cyrillic characters

Actual Results:  
each cyrillic character is replaced with two characters (garbled UTF-8)

Expected Results:  
cyrillic characters should be passed in codepage 1251

Comment 1

13 years ago
dup of bug 227268 IMHO.

Comment 2

13 years ago
yup

*** This bug has been marked as a duplicate of 227268 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.