Last Comment Bug 314525 - Server push jpegs don't display when doctype specified
: Server push jpegs don't display when doctype specified
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://code.nees.buffalo.edu/flexTPS/...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-31 09:31 PST by Jason P. Hanley
Modified: 2011-10-07 09:34 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jason P. Hanley 2005-10-31 09:31:27 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

I have a page that is using server push jpegs for streaming video. When I specifiy a xhtml doctype for this page, the video no longer displays. Without the doctype, the video displays correctly.

Reproducible: Always

Steps to Reproduce:
1. Go to a site with server push jpeg video (see URL attached) that has specified a (x)html doctype.
Actual Results:  
The video image does not display. Only the contents of the alt attribute are shown.

Expected Results:  
The server push jpeg will be displayed as a video.

I have also tried this with Firefox 1.0.7 on both Windows and Linux with the same behaviour. I also have a test page that has the doctype stripped to show that the jpeg push does work in that case. http://code.nees.buffalo.edu/flexTPS/test2.html
Comment 1 Jason P. Hanley 2005-10-31 09:34:06 PST
Sorry, the URL for a test case that does work (ie. has the doctype stripped) is http://code.nees.buffalo.edu/flexTPS/test1.html, not the one specified at the end of my original bug report.
Comment 2 Stuart Parmenter 2005-10-31 09:52:49 PST
Thats exciting... I can reproduce it too.  I'll take a look.
Comment 3 Stuart Parmenter 2005-11-01 00:23:14 PST
so I tried this with a trunk build today and wasn't able to reproduce it.  With the doc type you see the loading icon for a sec before it starts going, but it seems to work OK.  Not sure what the cause is on 1.0.x.

There was a server-push jpeg patch that went in at some point recently not sure if it was pre or post 1.8b5.

Can you test it on the trunk?  I'll grab a newer branch build and see if it is busted there.
Comment 4 Jason P. Hanley 2005-11-03 06:10:56 PST
I tried this on a nightly Firefox trunk and it does work there. Any chance for this to make it into the 1.5 release?
Comment 5 Benoit Jacob [:bjacob] (mostly away) 2011-10-07 09:33:03 PDT
Closing because:
 - comment 4 suggests that it's long been fixed
 - all testcase links are now broken
Comment 6 Benoit Jacob [:bjacob] (mostly away) 2011-10-07 09:34:03 PDT
Actually, given it's been confirmed and comment 4 says it's been fixed, FIXED is a happier ending for this one.

Note You need to log in before you can comment on or make changes to this bug.