Link from frame with target =<same frame> should not open new window (XML)

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
9 years ago

People

(Reporter: bradbell, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Suppose that you use XHTML with the *.xml extension for you input files,
the current frame is named "frame1" in the frameset,
and in the current frame you have the HTML source code:
   <a name="Heading">Heading</a>
   <a href="framelink_frame1.xml#Heading" target="frame1">Try this link</a>
when you select "Try this link" the browser should not do anything.

In Firefox 1.0.7 this works correctly; try
http://www.seanet.com/~bradbell/omhelp/framelink.xml

In Firefor 1.5 Beta 2 it opens a new window; try
http://www.seanet.com/~bradbell/omhelp/framelink.xml

In Firefox 1.5 Beta 2, using the *.htm extension, this works correctly; try
http://www.seanet.com/~bradbell/omhelp/framelink.htm


Reproducible: Always

Steps to Reproduce:
1. Open a new browser window
2. Go to the following web address:
   http://www.seanet.com/~bradbell/omhelp/framelink.htm
3. Select the link under the heading Bug (nothing will happen)
4. Select the link under the heading XML (to get XML version)
5. Select the link under the heading Bug (a new window will open)

Actual Results:  
If you use Firefox 1.0.7 in the steps above, 
it will function correctly.

If you use Firefox 1.5 Beta 2 in the steps above,
the HTML version will function correctly,
but the XML version will open a new window 
to display the results of the link selection.

Expected Results:  
The selection of the link should have not affect
(it links to itself).

This bug may be related to the following bug reports:
https://bugzilla.mozilla.org/show_bug.cgi?id=295226
https://bugzilla.mozilla.org/show_bug.cgi?id=312057

Comment 1

13 years ago
I can confirm that the described buggy behavior also appears in
the release version of Firefox 1.5.

I discovered this behavior with my own (validating) pages
with doctype XHTML 1.0 Frameset.

Updated

13 years ago
Blocks: 319551

Comment 2

13 years ago
*** Bug 319546 has been marked as a duplicate of this bug. ***
Component: General → Layout: HTML Frames
Product: Firefox → Core
QA Contact: general → layout.html-frames
Version: unspecified → 1.8 Branch
Confirming due to multiple reports and no luck finding dupe.

Testcases confirm bug on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 ID:2005111116.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Don't confirm bugs unless you have a good reason to think they're valid.  http://www.w3.org/TR/xhtml1/#h-4.10 suggests that this may not be, although I'm not sure.
(Reporter)

Comment 5

13 years ago
It appears to me that this may not be a bug; i.e.,
the name attribute is not necessarly supported by xhtml.

In the file
    http://www.w3schools.com/xhtml/xhtml_syntax.asp
under the heading
    The id Attribute Replaces The name Attribute
the following text appears:
    This is wrong:
         <img src="picture.gif" name="picture1" />
    This is correct:
          <img src="picture.gif" id="picture1" />
    Note: To interoperate with older browsers for a while, 
    you should use both name and id, with identical 
    attribute values, like this:
           <img src="picture.gif" id="picture1" name="picture1" />

I have tried using both the name and id attributes in this way
and it seems to work with both Firefox 1.5 and Internet Explorer 6.0
I remembered I had seen something like this before, so I looked it up...

(From bug 313818):
See http://www.w3.org/TR/xhtml1/#h-4.10.  If you want the same content to work
as both HTML and XHTML, you need to include both id and name.
-> INVALID


(In reply to comment #4)
> Don't confirm bugs unless you have a good reason to think they're valid. 
> http://www.w3.org/TR/xhtml1/#h-4.10 suggests that this may not be, although I'm
> not sure.

Yeah, sorry. I'll make sure to completely confirm stuff next time. :)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Component: Layout: HTML Frames → XML
QA Contact: layout.html-frames → xml
Resolution: --- → INVALID
*** Bug 324042 has been marked as a duplicate of this bug. ***
*** Bug 324042 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
*** Bug 325344 has been marked as a duplicate of this bug. ***

Updated

13 years ago
No longer blocks: 319551

Updated

9 years ago
Duplicate of this bug: 527255

Updated

9 years ago
Duplicate of this bug: 525828
You need to log in before you can comment on or make changes to this bug.