Closed Bug 314990 Opened 15 years ago Closed 15 years ago

Not using unique message id when msg doesn't have message id

Categories

(MailNews Core :: Backend, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Bienvenu, Assigned: Bienvenu)

References

Details

(Keywords: fixed1.8.1)

Attachments

(1 file)

We're not creating a unique message id when an incoming message id doesn't have a message-id. This leads to trouble when we delete duplicate messages, if mailers like Outlook don't deign to put a Message-ID in the message.  Fix upcoming.
Attached patch proposed fixSplinter Review
Like 4.x, generate an md5 hash of all the headers.
Attachment #201785 - Flags: superreview?(mscott)
Attachment #201785 - Flags: superreview?(mscott) → superreview+
alternatively, we could not delete dupes that don't have message IDs. But your solution is consistent with 4.x.

Does this mean if I get two messages from two different outlook users today that i might lose one in my trash due to my dupe action?
we already ignore messages w/o message-id's for the purpose of duplicate deletion. But, the code I changed used to make it so we think we have a non-empty message-id, and it's always the same message id!
And yes, sort of, to your Outlook question - basically, if you get two messages from an Outlook client with the same subject, (doesn't matter what the sender is), the second will be deleted if it came in the same session.

This only affects Outlook messages that get sent out onto the internet, I believe - some bizarre claim on MS's part that message-ids are bad somehow.
Comment on attachment 201785 [details] [diff] [review]
proposed fix

we'll definitely want this if we add ui for detecting and removing duplicate incoming messages.
Attachment #201785 - Flags: branch-1.8.1?
Comment on attachment 201785 [details] [diff] [review]
proposed fix

approving for the branch too.
Attachment #201785 - Flags: branch-1.8.1? → branch-1.8.1+
Status: NEW → RESOLVED
Closed: 15 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Duplicate of this bug: 301251
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.