Update Status "Install Pending" should be localizable

RESOLVED FIXED

Status

()

Toolkit
Application Update
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: dynamis (Tomoya ASAI), Unassigned)

Tracking

({fixed1.8.1, l12y, late-l10n})

unspecified
x86
Windows XP
fixed1.8.1, l12y, late-l10n
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Software update status "Install Pending" is now hardcoded:
http://lxr.mozilla.org/mozilla1.8/source/toolkit/mozapps/update/src/nsUpdateService.js.in#2232

This should be splited into updates.properties and read with string bunlde like
other status:
http://lxr.mozilla.org/mozilla1.8/source/toolkit/locales/en-US/chrome/mozapps/update/updates.properties#65
http://lxr.mozilla.org/mozilla1.8/source/toolkit/mozapps/update/src/nsUpdateService.js.in#1021

  p.s.
This status will be shown under "Update Installed" in the Update History dialog.
Installed and Pending is discrepancy and should be changed.

Updated

13 years ago
Keywords: l12y
Created attachment 205601 [details] [diff] [review]
patch v1.0

Sorry for letting this sit for so long. This one's simple.
Attachment #205601 - Flags: review?(darin)

Comment 2

12 years ago
Comment on attachment 205601 [details] [diff] [review]
patch v1.0

r=darin
Attachment #205601 - Flags: review?(darin) → review+

Comment 3

12 years ago
Has this patch been checked in?
Comment on attachment 205601 [details] [diff] [review]
patch v1.0

No, this hasn't been. I'd be happy to check it in, but I have no idea what needs to be done for patches that affect localizations. What needs to happen?
Attachment #205601 - Flags: approval-branch-1.8.1?(darin)

Comment 5

12 years ago
I don't think anything has to to be done, the localizers sync themselves the translations with the en-US locale by watching it

Updated

12 years ago
Attachment #205601 - Flags: approval-branch-1.8.1?(darin) → approval-branch-1.8.1+
Checked in on trunk.

Darin, is it too late for the branch (i.e. your approval-1.8.1+ is still good)?
Comment on attachment 205601 [details] [diff] [review]
patch v1.0

Just making sure it's still ok to check this in.
Attachment #205601 - Flags: approval1.8.1?
Flags: blocking-firefox2?
Keywords: late-l10n

Comment 8

12 years ago
Comment on attachment 205601 [details] [diff] [review]
patch v1.0

a=darin on behalf of drivers for the MOZILLA_1_8_BRANCH.  Please add the fixed1.8.1 keyword once this change is committed.
Attachment #205601 - Flags: approval1.8.1? → approval1.8.1+
Fixed on branch.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Updated

12 years ago
Flags: blocking-firefox2? → blocking-firefox2+
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.