define JS_C_STRINGS_ARE_UTF8 for non-ascii chars in Exceptions

RESOLVED WORKSFORME

Status

()

Core
Build Config
RESOLVED WORKSFORME
12 years ago
3 years ago

People

(Reporter: bc, Unassigned)

Tracking

({intl})

Trunk
mozilla2.0
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wanted-2.0])

Attachments

(1 attachment)

448 bytes, patch
bsmedberg
: review+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
Needed for bug 232182
Keywords: intl
Are there any cases where we wouldn't want this defined?
Who "we"?  Makefile.ref shouldn't, but README.html should mention the new compile-time option.

/be

Comment 3

12 years ago
Created attachment 202343 [details] [diff] [review]
v1.0

I would assume "we" means the gecko-based products since this is filed against Core:Build Config.  It seems like you're asking for a simple -DJS_STRINGS_ARE_UTF8 to be added unconditionally to the gecko build like we have for JS_THREADSAFE.
Attachment #202343 - Flags: review?(benjamin)
Comment on attachment 202343 [details] [diff] [review]
v1.0

Presuming from the commentary above that this has moa=brendan, sure.
Attachment #202343 - Flags: review?(benjamin) → review+

Comment 5

12 years ago
The patch has been checked in.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9alpha
I backed out rev 1.1547 of configure.in till we have our heads screwed back on straight, and have adjusted JS API clients that need deflation to ISO-Latin-1 to avoid getting UTF-8.  My fault for not coordinating harder.

/be
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Brendan:

Please tell me, what problem do we have?
The patch has checked-in to Trunk. But you was backing-out it.
Does SeaMonkey or Firefox or Thunderbird have a problem?
Or third party's product?
If it's latter, I think that we cannot understand the reason of backing-out.
Otherwise, our product has some problem, should we use the patch for we fix all regressions?

Comment 8

12 years ago
Please see bug 316178 comment 1. This has caused a very fundamental problem with XPConnect's conversion code.
thanks for the pointer.
I don't see a way we can fix this problem, really -- we have tons of interfaces that abuse |string| and expect to somehow "work" for random data.  :(
xpconnect could convert using some other method that keeps the current behaviour.
This should get attention during 1.9.

/be
Flags: blocking1.9?
Summary: define JS_STRINGS_ARE_UTF8 for non-ascii chars in Exceptions → define JS_C_STRINGS_ARE_UTF8 for non-ascii chars in Exceptions

Updated

11 years ago
Blocks: 352856
*** Bug 352856 has been marked as a duplicate of this bug. ***
No longer blocks: 352856
If this is too much for 1.9, it's definitely a Mozilla 2 to-do item, because we can and will break API compat.

/be
Blocks: 353107
Blocks: 353108
Flags: blocking1.9? → blocking1.9-
Whiteboard: [wanted-2.0]

Updated

10 years ago
Blocks: 397215
Assignee: nobody → general
Status: REOPENED → NEW
Target Milestone: mozilla1.9alpha1 → mozilla2.0
Duplicate of this bug: 426137
(Assignee)

Updated

3 years ago
Assignee: general → nobody
So much changed around encoding of js strings, the define doesn't exist anymore, I'll just resolve this WORKSFORME. Haven't heard of any of the issues mentioned here in the past few years, too.

Feel free to reopen if there's still a problem, though at this point, a new bug is probably better.
Status: NEW → RESOLVED
Last Resolved: 12 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.