Use colors to indicate parts of the URL in the address bar (especially the hostname)

RESOLVED DUPLICATE of bug 184074

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED DUPLICATE of bug 184074
12 years ago
12 years ago

People

(Reporter: Andre-John Mas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

With the issue of phishing, I feel that we may an address bar with coloured URLS might be useful, or some other solution to allow non-techie users to easily identify legitimate web site. The idea is to spot urls of the following form easily:

  http://www.ebay.com:312312312321@phisherco.com/abc/?122345

Also, maybe allowing an option to have the status bar to always show the web site in the status bar, even when the address bar is missing.

Reproducible: Always
(Reporter)

Comment 1

12 years ago
Note that HTTPS mode displays the name of the web site, but unsecured mode does not, so this should be extended to HTTP and FTP protocols.
Severity: normal → enhancement

Comment 2

12 years ago
Firefox already keeps usernames and passwords out of the address bar, but this idea could still be useful.  I've seen this idea mentioned elsewhere but I don't know where there's a bug on it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All
Summary: Colour address field URL → Use colors to indicate parts of the URL in the address bar (especially the hostname)

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 184074 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.