Last Comment Bug 315389 - Inline SVG links do not open new tabs/screens even if target is a unknown frame (e.g. _blank)
: Inline SVG links do not open new tabs/screens even if target is a unknown fra...
Status: RESOLVED DUPLICATE of bug 300868
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: 1.8 Branch
: x86 Windows 2000
: -- normal with 1 vote (vote)
: ---
Assigned To: General SVG Bugs
: Hixie (not reading bugmail)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 06:20 PST by reineckefuchs
Modified: 2006-02-02 08:22 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description reineckefuchs 2005-11-07 06:20:35 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8) Gecko/20051025 Firefox/1.5

Here is the inline SVG code, in case it's my fault. SVG displays fine but clicking the inline xlink does not open a new tab or window but replaces the active site. 

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>SVG embedded inline in XHTML</title>
</head>
<body>
<h1>Example</h1>
<hr/>
<svg xmlns="http://www.w3.org/2000/svg" version="1.1" xmlns:xlink="http://www.w3.org/1999/xlink">
<a xlink:href="http://www.mozilla.org/" target="_blank">
<text x="10" y="50" fill="blue" text-anchor="left" text-decoration="underline">
Linktext
</text>
</a>
</svg>
<hr/>
</body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Create document using above code, be sure to name ".xhtml"
2. Open the file with Firefox 1.5 RC1 and click the link text.


Actual Results:  
Notice that the link is opened in the same tab/window.

Expected Results:  
The link should open a new tab/window.

I do not know a workaround right now, I appreciate a notice if there is one. Should be fixed in a final "Inline-SVG-ready" version, though.
Comment 1 Tels 2005-12-11 09:20:53 PST
Adding a xlink:target="_blank" and/or xlink:show="new" does not change that behaviour.

This bug makes links in SVGs useles, especially for SVGs embedded via an <object> tag: the new link replaces the contents of the object-frame, instead the current tab/window. 

And opening a website in a 100x50 pixel iframe is just plain useless..

Btw, this happens on ALL platforms and OS, I couldn't change the fields on this bug, tho.
Comment 2 Nickolay_Ponomarev 2005-12-13 09:27:31 PST
Using xlink:show="new" WFM in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 if I set the tab options not to force all links to open in the same window / new tab?

target="_blank" seems invalid, xlink:target certainly is, as I coudn't find a mention of it in XLink specification.
Comment 3 Tels 2005-12-13 12:08:50 PST
See: http://www.w3.org/TR/SVG/linking.html

Search for "xlink:show", it also lists "target". It refers to the HTML/XHTML spec, and browsing that I read targe="_blank".

I have "open web browser links in: new tab" set and the SVG link
still opens inside the <object> tag space, not in the window or tab. See:

        http://s23.org/wiki/CCC#SVG

And scroll down to the very bottom and click on any node in the SVG
example. Can send a screenshot if you want :)

I wouldn't complain if it replaced the window/tab, but opening inside the SVG space doesn't make sense. (unless the newly loaded content is exactly the same size)
Comment 4 Nickolay_Ponomarev 2005-12-13 12:17:46 PST
ok, forgot to look in the SVG spec.
Comment 5 Victor Engmark 2006-01-12 01:37:37 PST
Probably related, I cannot right-click and select "Open in new tab/window", and middle-click does nothing.
Comment 6 Robert Longson 2006-02-02 08:22:21 PST

*** This bug has been marked as a duplicate of 300868 ***

Note You need to log in before you can comment on or make changes to this bug.