The default bug view has changed. See this FAQ.

xulappinfo.js.in should be included via EXTRA_PP_COMPONENTS

RESOLVED FIXED

Status

SeaMonkey
UI Design
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: mcsmurf, Assigned: jag (Peter Annema))

Tracking

({fixed1.8})

Trunk
fixed1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

856 bytes, patch
bsmedberg
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
The file xulappinfo.js.in uses the preprocessor to include the SeaMonkey version, appname, etc. But this information is only updated the first time the file is created (xulappinfo.js then), since it gets included via EXTRA_COMPONENTS. So when the SeaMonkey version changes, this file does not get updated (except you make clean). The file should be included in the Makefile via EXTRA_PP_COMPONENTS, then it gets preprocessed every compile run.

Comment 1

12 years ago
I'm no expert on that stuff, and I might easily have done something incomplete there... can you tell where in the code that is?
(Reporter)

Comment 2

12 years ago
Created attachment 202397 [details] [diff] [review]
Patch

This should fix it i think...xulappinfo.js.in needs to be moved/copied in CVS, will file bug for this then.
Attachment #202397 - Flags: review?
(Reporter)

Updated

12 years ago
Attachment #202397 - Flags: review? → review?(bsmedberg)
(Reporter)

Updated

12 years ago
Attachment #202397 - Flags: review?(bsmedberg) → review?(benjamin)
Comment on attachment 202397 [details] [diff] [review]
Patch

You're renaming the source file too, I presume.
Attachment #202397 - Flags: review?(benjamin) → review+
(Reporter)

Comment 4

12 years ago
Comment on attachment 202397 [details] [diff] [review]
Patch

Easy review i think :)
Attachment #202397 - Flags: superreview?(neil.parkwaycc.co.uk)
(Reporter)

Updated

12 years ago
Depends on: 315907

Comment 5

12 years ago
Comment on attachment 202397 [details] [diff] [review]
Patch

Doh, took me this long to figure out the rename issue...
Attachment #202397 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+

Comment 6

12 years ago
*** Bug 316198 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

12 years ago
checked in by Neil.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 8

12 years ago
Comment on attachment 202397 [details] [diff] [review]
Patch

requesting branch approval: quite small SeaMonkey-specific fix
Attachment #202397 - Flags: approval1.8rc2?

Updated

12 years ago
Attachment #202397 - Flags: approval1.8rc2?

Comment 9

12 years ago
Comment on attachment 202397 [details] [diff] [review]
Patch

re-requesting 1.8 branch approval for this SeaMonkey-only patch
Attachment #202397 - Flags: approval1.8.0.1?

Comment 10

12 years ago
Comment on attachment 202397 [details] [diff] [review]
Patch

oh, wait... one should read all mail before reacting to some ;-)
Attachment #202397 - Flags: approval1.8.0.1?

Comment 11

12 years ago
checked into branch (cleared to land by mtschrep in email to
seamonkey-council).
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.