Closed Bug 31550 Opened 20 years ago Closed 20 years ago

Browser freezes on complex text only html file

Categories

(SeaMonkey :: General, defect, P3)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 18480

People

(Reporter: majix, Assigned: cbegle)

References

()

Details

(Keywords: crash)

Overview Description:
Browser renders about 1/3 of the html file, then stops but still displays 
"Document: done" on the status bar. If I use the horizontal scrollbar on the 
page the browser freezes completely and I have to use control-alt-del (several 
times) to shut down the application.

The file is a largish (~420k) text only html file with a lot of font color 
changes.

Netscape 4.7 renders the page in a little over 5 seconds while IE4.0 takes a 
good 10 minutes on my P200/64MB machine.

Steps to Reproduce: 
1) Enter http://rio.dhs.org/penguin.html in the location bar
2) After the page has apparently stopped loading, move the horizontal scrollbar

Actual Results: 
Browser stops responding and must be explicitly killed.

Expected Results:
Page should render to the finish, not stop at about 1/3 and not freeze the 
browser.

Tested builds, date & Platform:
2000/03/09/13 on Win98
2000/03/11/15 (newest as of writing) on Win98
*** Bug 31677 has been marked as a duplicate of this bug. ***
I have to comment first, that page is SO NEAT =)

I couldn't even get it to finish without crashing.
(BuildID:2000031306, win98)

Here's two dumps i got from the crash on that page.
Windows 98 dump:
MOZILLA caused a stack fault in module GKHTML.DLL at 0167:601e7f25.
Registers:
EAX=00f53358 CS=0167 EIP=601e7f25 EFLGS=00010212
EBX=00f5334c SS=016f ESP=00591ebc EBP=005920c8
ECX=00f31680 DS=016f ESI=00592130 FS=678f
EDX=00f31150 ES=016f EDI=00f51ba0 GS=0000
Bytes at CS:EIP:
53 8b 5d 0c 56 57 33 ff 33 f6 83 3b ff 89 7d cc 
Stack dump:
00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
00000000 00000000 00000000 00000000 00000000 00000000 00000000 

MOZILLA caused a stack fault in module GKHTML.DLL at 0167:601e7f25.
Registers:
EAX=014633c8 CS=0167 EIP=601e7f25 EFLGS=00010202
EBX=014633bc SS=016f ESP=00591f10 EBP=0059211c
ECX=01441680 DS=016f ESI=00592184 FS=608f
EDX=01441150 ES=016f EDI=01461c00 GS=0000
Bytes at CS:EIP:
53 8b 5d 0c 56 57 33 ff 33 f6 83 3b ff 89 7d cc 
Stack dump:
00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
00000000 00000000 00000000 00000000 00000000 00000000 00000000 

Marking confirmed, I'm sure you gen get some die-hard linux fan to fix this bug 
before beta1 (just kidding, look at the url and you'll see what i mean). What 
component do I put this in? Leaving browser-general for now. Adding crash to 
keyword.
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Should be dup of 18480

macmahon@traclabs.com, good catch.  marking duplicate of bug 18480

*** This bug has been marked as a duplicate of 18480 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verifed dupe..
please verify when main bug is fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.