"Do this automatically" in "You have chosen to open" assumes too much, need right click "open link with"

RESOLVED DUPLICATE of bug 348808

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 348808
13 years ago
10 years ago

People

(Reporter: bzipitidoo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

I often use several different programs on the same type of file.  For example, on some PDF files only one of ggv or xpdf can view them.  So I need both.  The same goes for Word Doc files with OpenOffice or AbiWord.  I don't want to use the GIMP just to view an image file if a smaller, faster loading app (xv? Firefox?) can handle it.  Also, a hex editor or hex viewer such as hexdump or xxd could view any file type.

"Do this automatically for files like this from now on" is mostly useless to me.

Reproducible: Always

Steps to Reproduce:



Expected Results:  
Maybe another option in 2 places:  in the menu that pops up when right clicking on a link, and in the "you have chosen to open" dialog.  The option would be "open with" and would list the apps that have been used to open that type.  (User would be able to edit that list somehow)  Like, would see xpdf and ggv listed for a PDF file.  The "you have chosen to open" dialog already has "open with"; all that it needs is a list of apps with "other..." at top or bottom.

Comment 1

11 years ago
the new application selector should satisfy this
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348808
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.