Closed Bug 315895 Opened 15 years ago Closed 15 years ago

when parsing a link with a slash typo (\ in place of/) the parser does not correct the problem

Categories

(Core :: DOM: HTML Parser, enhancement)

PowerPC
macOS
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: jasonb, Assigned: mrbkap)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050914 Camino/1.0a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050914 Camino/1.0a1

when clicking on a link on the intranet site at work that is incorrectly coded with a \ instead of a / in the link address I get an error message, Safari (and IE on a PC, i think) resolve the typo and parse a correct link

Reproducible: Always

Steps to Reproduce:
1. try the following code in different browsers (i found the problem in camino but not in safari:

<a href="http://www.mozilla.org/quality\most-frequent-bugs">Text Link</a>
Actual Results:  
you link to http://www.mozilla.org/quality%5cmost-frequent-bugs which does not actually exist and get an error message and so have to type the address in by hand

for EG there is a link on my intranet at work with this problem but all the PCs with MSIE resolve the issue, I have to type in the link by hand into camino

Expected Results:  
the Parser sees and resolves the mistake

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.