Shortcuts: cmd-opt-w should close all non-docked windows, cmd-opt-m should minimize all

VERIFIED FIXED

Status

Camino Graveyard
Accessibility
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Jacob Rus, Assigned: froodian (Ian Leue))

Tracking

({fixed1.8.1})

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1

In almost all OS X apps, option-w closes all windows, and option-m minimizes all windows.  In Camino, these shortcuts don't work.    Also, the menu commands should update when option is held down, and selecting the menu commands with option held down should close, respectively minimize, all windows.

Reproducible: Always

Steps to Reproduce:
1. press option-w, option-m, or hold option and select the relevant menu commands


Actual Results:  
nothing

Expected Results:  
all windows should be closed, respectively minimized

Check the operation of Safari for an example of how this should work

Comment 1

12 years ago
I think you mean cmd-option.

And no, it doesn't work in Camino. This is a standard Mac OS behaviour, though, and should work.

The menu commands not updating is part of the post-10.2 stuff, which won't get fixed until 10.2 support is dropped. (See bug 311840, the tracker for all post-10.2 "to be implemented" bugs.)

I'll see if I can figure anything out on this within the next 24 hours or so.

cl
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

12 years ago
Yeah, I do mean Cmd-opt-w, cmd-opt-m.  Sorry.  One thing to note: option-clicking the close and minimize widgets does do the right thing.
Summary: Shortcuts: option-w should close all non-docked windows, option-m should minimize all → Shortcuts: cmd-opt-w should close all non-docked windows, cmd-opt-m should minimize all
did this used to work? have we regressed, or did it never work?
Didn't work in 0.8.4.

Comment 5

12 years ago
IMO, when we fix this, we should NOT put up the "are you sure" warning, since holding down option is a deliberate action that's difficult to do accidentally.

cl
I'm not sure I like the two meanings of opt colliding here--opt as "all" and opt as "override confirmation dialogue"--although as Chris noted, it is something that that a user has to pretty explicitly invoke.... 
Depends on: 181978

Comment 7

12 years ago
Hrmmm...

Safari uses cmd-opt-w for "close other tabs", and cmd-shift-opt-w for "close all windows". Cmd-shift-w closes the frontmost window with multiple tabs in it;  neither we nor Safari properly map cmd-shift-w to "close" in the single-tab case. (In such a case, cmd-shift-w does nothing, and this should be filed as a new bug against Camino, IMO. If someone files it before I get around to it, please CC me.)

I personally think cmd-shift-opt-w is pretty cumbersome, and it makes it darn near impossible to close all windows. I also think the "close other tabs" action is something that gets used so rarely, it doesn't deserve a key shortcut.

However, while opt is the traditional Mac OS modifier for "all", I'm not sure what user expectation is here. All what? All tabs? Or all windows? The only commonality I can find among apps that I use regularly is cmd-shift-w closes the current multi-tabbed window. Cmd-opt-w is either unsupported (Camino, Adium) or does something else entirely (Safari).

What does Firefox do in this case?

My preference would be that we retain the traditional Mac OS meaning of the option modifier applying to all *windows* of the active application, and fix this bug as filed. If it wasn't clear above, I don't like Safari's shortcuts for these actions at all.

Incidentally, I don't think -- or at least, I wasn't aware -- there are two different meanings for option (see Smokey's comment 6). Cmd and opt are unlikely to be pressed at the same time by accident, so I can see how the opt key would seem to have the meaning of "suppress warnings", though.

IMO, the proposed behaviour furthers the meaning of option-as-"all"-modifier; the fact that the action is unlikely to be selected by accident is the reason we shouldn't display the confirmation/warning dialog. I think we should be displaying that dialog as little as possible. It's *extremely* helpful in the accidental cmd-W/cmd-Q mix-up case, but it's also *extremely* annoying when I've deliberately performed a triggering action, like clicking on the close box (I know this is a filed bug but can't find it right now) or keying one of the shortcuts discussed here.

cl
(Assignee)

Comment 8

11 years ago
The nib in bug 181978 fixes this.
Assignee: mikepinkerton → stridey
QA Contact: accessibility
Fixed (branch/trunk) by the checkin for bug 181978.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
We actually close all windows, docked on un-docked.  If that's a real problem for anyone, file a new bug.
Keywords: fixed1.8.1
(Assignee)

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.