normalize truncates content of long textarea

RESOLVED DUPLICATE of bug 300691

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 300691
14 years ago
11 years ago

People

(Reporter: jdunck, Unassigned)

Tracking

({dataloss})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

Large content textboxes (probably the key is multiple text nodes in the textarea content) is truncated when calling normalizing.

Reproducible: Always

Steps to Reproduce:
Steps outlined in testcase attachments.
Reporter

Comment 1

14 years ago
Posted file testcase
Reporter

Comment 2

14 years ago
bumped to critical due to data loss.
Severity: normal → critical

Comment 3

14 years ago
This affects users of my AutoLink user script who edit long Wikipedia pages.

Bug 300691, "normalize() function on textarea removes text that was appended with dom method", seems related.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss

Updated

14 years ago
Flags: blocking1.8.1?

*** This bug has been marked as a duplicate of 300691 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Flags: blocking1.8.1?

Updated

11 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.