Closed Bug 316065 Opened 15 years ago Closed 15 years ago

Building fails when linking against libXft on Debian

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 305185

People

(Reporter: nthomas, Unassigned)

Details

Attachments

(1 file)

On Debian (and derived distro's like Ubuntu) libXft.so.2 was moved from /usr/X11R6/lib to /usr/lib in version 2.1.1-3 of the package libxft2.
(http://packages.debian.org/changelogs/pool/main/x/xft/xft_2.1.7-1/changelog)

Firefox fails at the final link when it can't resolve symbols from this library (I'll attach a build log shortly). 

A simple workaround (unintended consequences unknown) is to add $(MOZ_XFT_LIBS) to line 94 of mozilla/browser/app/Makefile.in:
 # Add explicit X11 dependency when building against X11 toolkits
 ifneq (,$(filter gtk gtk2 xlib,$(MOZ_WIDGET_TOOLKIT)))
 LIBS += $(XLDFLAGS) $(XLIBS) $(MOZ_XFT_LIBS)
 endif

MOZ_XFT_LIBS is "-lXft -lfreetype -lz -lXrender -lX11 -ldl -lfontconfig" my objdir's config/autoconf.mk
Attached file Final link error
Forgot to say that this is for Firefox code from the MOZILLA_1_8_BRANCH. 

Since the Debian change to libXft took place Oct 2003, something else must have changed. I was able to build successfully using Ubuntu 05.04 but the problem occurs since I updated to 05.10

*** This bug has been marked as a duplicate of 305185 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.