If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

myrewardzone.com - Cannot log in, incorrect getElementById usage

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED WORKSFORME
12 years ago
2 years ago

People

(Reporter: Ronald Mendoza, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

I can no longer log in to the Best Buy Reward Zone website, located at http://www.myrewardzone.com. Clicking on the SIGN IN button results in no action. The website used to work with Firefox up until about a week ago. Problem with Firefox, or the website?

Reproducible: Always

Steps to Reproduce:
1. Browse to http://www.myrewardzone.com
2. Enter member ID or email address, and password, then click SIGN IN
3.

Actual Results:  
Nothing appears to happen, and you do not sign in to the website.

Expected Results:  
You should have been signed into the website.

Comment 1

12 years ago
JavaScript Console reports this error in Firefox 1.5 branch:

Error: document.getElementById("logonForm") has no properties
Source File: http://www.myrewardzone.com/js/standard.js
Line: 50

Firefox is not going to support what the website is incorrectly trying to do, see bug 174617.  So over to tech evangelism.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Summary: Cannot log in to website. Used to work up to about a week ago. → myrewardzone.com - Cannot log in, incorrect getElementById usage
*** Bug 321050 has been marked as a duplicate of this bug. ***
The site has been updated. I don't have an account to test but should no longer be an issue. Please reopen if the bug still exists.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.