takes a very long time to save an image downloaded from the web

RESOLVED DUPLICATE of bug 159107

Status

RESOLVED DUPLICATE of bug 159107
13 years ago
13 years ago

People

(Reporter: dainisk, Unassigned)

Tracking

1.7 Branch
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/312.5.1 (KHTML, like Gecko) Safari/312.3.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915

It takes soemtimes as long as 45 seconds to save a relatively small image already downloaded from the web.  the 'beach ball' just goes round and round until finally the 'save' screen appears momentarily.  Sometimes, the beach ball goes round and round again for another 10 seconds or so before the image is saved.
IE and Safari save the same images almost instantaneously.  I am using a G5 Mac, 10.3.9, with near 1G of RAM.  It doesn't matter if other applications are running or not.

Reproducible: Always

Steps to Reproduce:
1.any web downloaded image (jpg or other type of file).
2.
3.

Actual Results:  
using either right mouse button or save menus.

Expected Results:  
as described

Comment 1

13 years ago
David, can you please try the SeaMonkey 1.0a release available at http://www.mozilla.org/projects/seamonkey/ and see if the issue still exists? Loads of bugs have been fixed since the 1.7 branch was cut (Mozilla 1.7.12 is based on 1.7 branch code and SeaMonkey 1.0a is based on 1.8 branch code). 

Comment 2

13 years ago
How large is the downloads.rdf file in your Mozilla profile directory?
Version: unspecified → 1.7 Branch

Updated

13 years ago
Summary: takes a very long time to save an image downlaoded from the web → takes a very long time to save an image downloaded from the web
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> How large is the downloads.rdf file in your Mozilla profile directory?
> about 4.6M

Comment 4

13 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > How large is the downloads.rdf file in your Mozilla profile directory?
> about 4.6M

Then close Mozilla, delete the file and try again. Does that help against your problems? If so, this is a dupe of Bug 159107.
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > How large is the downloads.rdf file in your Mozilla profile directory?
> > about 4.6M
> 
> Then close Mozilla, delete the file and try again. Does that help against your
> problems? If so, this is a dupe of Bug 159107.
> Yup - solved the problem - thanks!!!
But, I guess how would a user ever know to do that - deleting key files can often have some disastorous results?

Comment 6

13 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Then close Mozilla, delete the file and try again. Does that help against your
> > problems? If so, this is a dupe of Bug 159107.
> Yup - solved the problem - thanks!!!
> But, I guess how would a user ever know to do that - deleting key files can
> often have some disastorous results?

This is the download history. For FF the problem is already "solved", you can activate the option to remove completed downloads from the history. For SeaMonkey something similiar is work in progress. As workaround you could write-protect the file.



*** This bug has been marked as a duplicate of 159107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.