message composition window grayed-out

VERIFIED DUPLICATE of bug 307672

Status

defect
VERIFIED DUPLICATE of bug 307672
14 years ago
11 years ago

People

(Reporter: eyalroz, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
With recent nightlies, sometimes I get to a situation in which when I open a message compose window, the fields are grayed-out and I can't enter any text. I can't consistently reproduce this, but it's happened to me a lot. Restarting mozilla fixes the problem; sometimes closing all open composition windows and/or switching composition from text to HTML or vice-versa fixes the problem.

Comment 1

14 years ago
(In reply to comment #0)
> Restarting mozilla fixes the problem; sometimes closing all open
> composition windows and/or switching composition from text to HTML or
> vice-versa fixes the problem. 

Having the problem fixed by "switching from text to HTML" implies a cached-composition-window problem.  Next time you see it, try following it up by immediatley opening *another* composition window.

I assume these are trunk builds (1.6a1).  Do you have any extensions installed that might be causing this?
Reporter

Updated

14 years ago
Keywords: qawanted
Reporter

Comment 2

14 years ago
(In reply to comment #1)
> I assume these are trunk builds (1.6a1).  Do you have any extensions installed
> that might be causing this?
> 

Maybe... BiDi Mail UI. Mozilla gives me hell whenever I install a nightly - fscking up the chrome until I remove and reinstall the extension. Also, there's

https://bugzilla.mozilla.org/show_bug.cgi?id=311963

But all this is probably unrelated to the graying-out thing. Haven't been able to reproduce it again (although recent nightlies are otherwise flakey).
Reporter

Comment 3

14 years ago
Seeing it again just now, with sm 2005-11-27. JS console says:

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgCompose.initEditor]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/messengercompose/MsgComposeCommands.js :: InitEditor :: line 3187"  data: no]
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 3187

Error: gMsgCompose.editor has no properties
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 192


Still not sure how to reproduce this. This time I was composing HTML e-mail (don't ask why).
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 307672 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.