Last Comment Bug 316248 - status bar does not display URL on focus
: status bar does not display URL on focus
Status: VERIFIED DUPLICATE of bug 267664
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: General SVG Bugs
: Hixie (not reading bugmail)
:
Mentors:
https://bugzilla.mozilla.org/attachme...
: 316951 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-13 01:43 PST by jonathan chetwynd
Modified: 2007-03-16 07:15 PDT (History)
5 users (show)
martijn.martijn: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description jonathan chetwynd 2005-11-13 01:43:17 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

onmouseover one expects the URL to be displayed in the status bar.
default Firefox disables js change to status bar.
hence it is critical for keyboard users that the status bar displays the destination URL of the element in focus.


Reproducible: Always

Steps to Reproduce:
1.open URL
2.change focus
3.observe status bar

Actual Results:  
no change

Expected Results:  
destination URL of element holding focus displayed in status bar.

Please could someone add an attachment showing how simply to use js until this bug is fixed? I can't figure out how ~:"
Comment 1 Ria Klaassen (not reading all bugmail) 2005-11-13 03:23:28 PST
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051112 Firefox/1.5 ID:2005111223

Not sure if I understand it right but I see two different urls appear in the statusbar when I hover the images.
Comment 2 jonathan chetwynd 2005-11-13 04:25:14 PST
sorry, you need to change focus using the keyboard, tab button, then the colour will change from blue to red, and no URL is displayed in status bar.
Comment 3 Ria Klaassen (not reading all bugmail) 2005-11-13 05:12:54 PST
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051112 Firefox/1.5 ID:2005111223

OK, no address in statusbar when the color changes. :)
Comment 4 jonathan chetwynd 2005-11-22 23:27:14 PST
*** Bug 316951 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2007-01-06 09:13:49 PST
Fixed by my work for bug 267664. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 267664 ***

Note You need to log in before you can comment on or make changes to this bug.