Closed Bug 316279 Opened 19 years ago Closed 19 years ago

Previous page position lost when using Back btn to navigate

Categories

(Core :: Layout, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 215405

People

(Reporter: mozilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1

If I'm reading a long web page and cclick on  a link, it takes me to a news page. If I then hit the Back button, it takes me to the previous page but  does not restore me to the place I was reading so I need to find that spot again. It should be able to remember the spot and automatically scroll down to it. 

Reproducible: Always

Steps to Reproduce:
1. Load up a link page with links near the middle of the content.
2. Scroll down to a link near the middle of the page.
3. Click a link and wait for the new page to load.
4. Hit the Baxck button.
Actual Results:  
The previous page loads but mI am left at the top of the page, which I've already finished reading.

Expected Results:  
TOnce the page has finished loading, it should automatically scroll down to the point I was at when I clicked the link so I can continue from there.

Any typos in this bug are duue to the fact that the cursor  is not positiond properly in Camino so I can't see the last few characters I am typing.
I'm not seeing this behaviour. Antonio do you have a test URL?
Hmm. that is a little odd; it doesn't happen on most pages, although I assumed it did. However, I do have a test URL where it can be reproduced reliably.  so I am adding it to the URL field of this bug.
I've seen this too, but haven't been able to reproduce it reliably... until now. That URL you gave reproduces the problem perfectly, so, confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
We don't cache that page because the site's Apache server tell Camino not to.
Oh, I didn't realize caching was a necessary prerequisite to repositioning but I guess if we have no gway of knowing whether the page has changed then it may not always make sense to reposition the page. 
Does FF do the same thing we do? (And Safari?)
Safari manages to get back to the same position, although I'm not entirely sure Safari is respecting the server's directive not to cache the page.

cl
But FF does not.
I reckon that Camino/Gecko is simply following the HTTP headers telling it to not cache the page; it's sending the following headers:

Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Interestingly, when manually reloading a page, the position is remembered properly.

cl
Doesn't work in FF either.
Component: General → Layout
Product: Camino → Core
Version: unspecified → Trunk
This is being caused by "Cache-Control: no-store".

I do see the page position reverting to the top on manual reload.
(In reply to comment #12)
> This is being caused by "Cache-Control: no-store".
> 
> I do see the page position reverting to the top on manual reload.

Woops, yeah, you're right. I was saying that based on a test with a different page.

cl
> This is being caused by "Cache-Control: no-store".

i'm sure this is a dupe, i think i've seen this around before.
Assignee: mikepinkerton → nobody
QA Contact: layout

*** This bug has been marked as a duplicate of 215405 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.