"try again" button of error pages reload wrong URL

RESOLVED DUPLICATE of bug 302115

Status

()

RESOLVED DUPLICATE of bug 302115
13 years ago
13 years ago

People

(Reporter: naughtyhostage+bugzilla, Assigned: adamlock)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

After you encounter a XUL error page, go to another site, go back to the error page and press "try again" it will reload the newly loaded site.

Reproducible: Always

Steps to Reproduce:
1. Goto http://www.fjhsdkjdshfkj.com, wait for error page to appear
2. Goto http://www.winamp.com
3. Hit back
4. Hit "try again"

OR

1. Goto http://www.winamp.com
2. Goto http://www.fjhsdkjdshfkj.com, wait for error page to appear
3. Hit back
4. Hit forward
5. Hit "try again"
Actual Results:  
http://www.winamp.com loads

Expected Results:  
http://www.fjhsdkjdshfkj.com should load
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → adamlock
Component: General → Embedding: Docshell
Product: Firefox → Core
QA Contact: general → adamlock
Version: unspecified → 1.8 Branch

Comment 1

13 years ago
dupe of bug 302115

*** This bug has been marked as a duplicate of 302115 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.