Closed Bug 316715 Opened 15 years ago Closed 15 years ago

should enable IME on applet and embed elements

Categories

(Core :: Internationalization, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9alpha1

People

(Reporter: masayuki, Assigned: masayuki)

References

()

Details

(Keywords: inputmethod, intl, regression)

Attachments

(1 file, 3 obsolete files)

This is regression of bug 55751.
We should enable IME if applet or embed element have focus.
Attached patch Patch rv1.0 (obsolete) — Splinter Review
Attachment #203268 - Flags: superreview?(roc)
Attachment #203268 - Flags: review?(roc)
Status: NEW → ASSIGNED
Attached patch Patch rv1.1 (obsolete) — Splinter Review
Thank you, Kimura-san!
Attachment #203268 - Attachment is obsolete: true
Attachment #203277 - Flags: superreview?(roc)
Attachment #203277 - Flags: review?(roc)
Attachment #203268 - Flags: superreview?(roc)
Attachment #203268 - Flags: review?(roc)
Attached patch Patch rv1.2 (obsolete) — Splinter Review
Sorry, there are some case that embed element creates box by CSS.
We need to check for embed element is loaded plug-in too.
Attachment #203277 - Attachment is obsolete: true
Attachment #203279 - Flags: superreview?(roc)
Attachment #203279 - Flags: review?(roc)
Attachment #203277 - Flags: superreview?(roc)
Attachment #203277 - Flags: review?(roc)
Attachment #203279 - Flags: superreview?(roc)
Attachment #203279 - Flags: superreview+
Attachment #203279 - Flags: review?(roc)
Attachment #203279 - Flags: review+
Attachment #203279 - Attachment is obsolete: true
checked-in.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
+  if (nsObjectLoadingContent::Type() == eType_Plugin)
+    return nsIContent::IME_STATUS_ENABLE;
+  return nsIContent::GetDesiredIMEState();

1) why not just Type(), like in IsFocusable()?
2) why not call the method of the direct superclass (nsGenericHTMLElement, if I recall correctly)?
1. If the method names are conflict by some inherited classes, is this better way?
2. Ah, this may be bad...
(In reply to comment #8)
> 1. If the method names are conflict by some inherited classes, is this better
> way?

Sorry, I don't understand what you mean... is there another class in this hierarchy that has a Type() method? In general, I would leave off the class name, to make the code easier to read.
You need to log in before you can comment on or make changes to this bug.