recurring events on calendars subscribed to through webcal are incorrectly displayed

RESOLVED DUPLICATE of bug 310221

Status

RESOLVED DUPLICATE of bug 310221
13 years ago
13 years ago

People

(Reporter: emily, Assigned: mostafah)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: http://www.mozilla.org/projects/calendar/sunbird_download.html

Events set to recurr once a week in iCal, when subscribed to through webcal, Sunbird displays every day of the week, multiple times per day. 

Reproducible: Always

Steps to Reproduce:
1.Create an iCal calendar with an event set to repeat weekly and not expire. 
2.Create a webcal account and upload your calendar. 
3.Subscribe to that calendar on Sunbird. 

Actual Results:  
The event is displayed not weekly, but daily, once a day on the week it was originally entered, twice a day the next week, three times the third, so on, for each month. However, if you edit the event and check the recurrence, it says it is set to recurr once a week. 

Expected Results:  
That the event would only be displayed once per day, once per week.

Comment 1

13 years ago
Confirmed that this is a problem in Sunbird 0.3 alpha 1.  Attempted to confirm against the latest nightly (2005-11-16), but adding remote calendars over webcal seems to be broken (refuses to advance past the "Customize Your Calendar" step).

Several screenshots of the problem in question:
http://users.mudbugmedia.com/~seanbug/qa/sunbird/316728/event_01_display.jpg
http://users.mudbugmedia.com/~seanbug/qa/sunbird/316728/event_01_general_details.jpg
http://users.mudbugmedia.com/~seanbug/qa/sunbird/316728/event_01_recurrence_details.jpg

The VEVENT in question is:
BEGIN:VEVENT
DTSTART;TZID=America/New_York:20051007T100000
SUMMARY:status report
UID:9F276B60-6606-45B4-BBFE-1986812CC2B1-FB233D90-D1F2-4F19-8136-E914172
 44E5E
SEQUENCE:4
DTSTAMP:20051021T160439Z
RRULE:FREQ=WEEKLY;INTERVAL=1
DURATION:PT1H
END:VEVENT


This seems to also be a problem with other recurring events in remote iCal calendars, regardless of frequency.  Note the following:

BEGIN:VEVENT
DTSTART;TZID=US/Central:20040701T000000
EXDATE;TZID=US/Central:20040701T000000
EXDATE;TZID=US/Central:20041004T000000
SUMMARY:Create Archive DVDs of Snap 3 and Rackspace
UID:E6E4D564-8345-43E1-B3CE-52C224DE2439-432007D6-5734-4E50-A200-36FF777
 B1BA7
DTSTAMP:20041110T165152Z
RRULE:FREQ=YEARLY;INTERVAL=1;BYMONTH=1,4,7,10;BYDAY=1MO
DURATION:PT1H
END:VEVENT

Also, pay close attention to the frequency, and screenshots of the resulting behaviour:
http://users.mudbugmedia.com/~seanbug/qa/sunbird/316728/event_02_display.jpg
http://users.mudbugmedia.com/~seanbug/qa/sunbird/316728/event_02_general_details.jpg
http://users.mudbugmedia.com/~seanbug/qa/sunbird/316728/event_02_recurrence_details.jpg

As someone who frequently works from remote PCs and needs to connect to remote iCal calendars, this is problematic.
(In reply to comment #1)

If I look at your examples this seems to be a duplicate of bug 310221.

If you agree please resolve as duplicate of bug 310221.

Comment 3

13 years ago
(In reply to comment #2)

Without being familiar with the source, I cannot say for certain, but that would appear to be a reasonable assumption, and would also account for the behaviour regarding the end date in the General details for the event (ie. the "Your start date is after your end date" error message).

Additionally, it appears that Apple iCal does not create a DTEND for VEVENT's that repeat indefinitely.  If anyone with a Mac can confirm this, then this bug should be marked as a duplicate, and the description of bug 310221 should be updated to make mention of the incompatibility with .ics files created by iCal, which will, hopefully, curtail the number of future duplicates.
After adding DTEND to events everything works. This will be fixed with bug 310221; resolving this one as duplicate.

*** This bug has been marked as a duplicate of 310221 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.