The default bug view has changed. See this FAQ.

Crash with moz-border-radius and small font-size

VERIFIED FIXED

Status

()

Core
Layout: View Rendering
--
critical
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: Bernd)

Tracking

(6 keywords)

Trunk
x86
Windows XP
crash, regression, testcase, verified1.7.13, verified1.8.0.1, verified1.8.1
Points:
---
Bug Flags:
blocking1.7.13 +
blocking-aviary1.0.8 +
blocking1.8.1 +
blocking1.8.0.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: regression from 265736, URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
This came from http://forums.mozillazine.org/viewtopic.php?t=342177

The url testcase crashes current trunk and branch builds.
This regressed between 2005-10-28 and 2005-10-30 on trunk:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-10-28+07%3A00%3A00&maxdate=2005-10-30+07%3A00%3A00&cvsroot=%2Fcvsroot
The most likely cause of this regression would be bug 265736, I guess (since it is also a regression on branch).

Comment 1

12 years ago
TalkbackID: TB11951173G
(Assignee)

Comment 2

12 years ago
mine
Assignee: roc → bernd_mozilla
(Assignee)

Comment 3

12 years ago
Created attachment 203422 [details] [diff] [review]
patch
(Assignee)

Updated

12 years ago
Attachment #203422 - Flags: superreview?(roc)
Attachment #203422 - Flags: review?(roc)
Attachment #203422 - Flags: approval1.8.0.1?
Attachment #203422 - Flags: superreview?(roc)
Attachment #203422 - Flags: superreview+
Attachment #203422 - Flags: review?(roc)
Attachment #203422 - Flags: review+
(Assignee)

Comment 4

12 years ago
fix checked in
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Blocks: 317900
Flags: blocking1.8.0.1?

Comment 5

12 years ago
*** Bug 317900 has been marked as a duplicate of this bug. ***
No longer blocks: 317900
(Reporter)

Comment 6

11 years ago
Verified fixed, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051215 Firefox/1.6a1
Status: RESOLVED → VERIFIED

Comment 7

11 years ago
Comment on attachment 203422 [details] [diff] [review]
patch

Please land in 1.8 and 1.8.0 branches.  Thanks!
Attachment #203422 - Flags: approval1.8.1+
Attachment #203422 - Flags: approval1.8.0.1?
Attachment #203422 - Flags: approval1.8.0.1+
Flags: blocking1.7.13?
Flags: blocking-aviary1.0.8?
Whiteboard: regression from 265736
(Assignee)

Comment 8

11 years ago
fixed on branches
Keywords: fixed1.8.0.1, fixed1.8.1

Comment 9

11 years ago
v.fixed on 1.8.0.1 with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060104 Firefox/1.5.0.1 using the URL testcase.
Keywords: fixed1.8.0.1 → verified1.8.0.1
Flags: blocking1.8.1+
Flags: blocking1.8.0.1?
Flags: blocking1.8.0.1+
(Assignee)

Comment 10

11 years ago
If this should be approved for 1.7.13 and 1.0.8 then it needs the patch from bug 265736 too, as this is only the cleanup after that bug.
Keywords: fixed1.8.0.1
(Reporter)

Comment 11

11 years ago
*** Bug 322901 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Keywords: fixed1.8.0.1
Flags: blocking1.7.13?
Flags: blocking1.7.13+
Flags: blocking-aviary1.0.8?
Flags: blocking-aviary1.0.8+
Comment on attachment 203422 [details] [diff] [review]
patch

a=dveditz
Attachment #203422 - Flags: approval1.7.13+
Attachment #203422 - Flags: approval-aviary1.0.8+
Keywords: fixed-aviary1.0.8, fixed1.7.13
verified on the 1.0.1 branch using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20060209 Firefox/1.0.7. On crash using URL testcase. Adding keyword.
Keywords: fixed-aviary1.0.8 → verified-aviary1.0.8
verified no crash with URL testcase on the 1.7 branch using Mozilla 1.7.13
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.13) Gecko/20060302.
Keywords: fixed1.7.13 → verified1.7.13
verified with Fx 2.0b2 builds from 22060821
Keywords: fixed1.8.1 → verified1.8.1
You need to log in before you can comment on or make changes to this bug.