getPropertyValue sometimes returns null for what appears to be a valid CSS property

RESOLVED DUPLICATE of bug 47159

Status

()

Core
DOM: CSS Object Model
--
major
RESOLVED DUPLICATE of bug 47159
12 years ago
12 years ago

People

(Reporter: clc4tts, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

getPropertyValue cannot retrieve "voice-family" property value.

I know that my code for retrieving CSS property values is correct as I can retrieve the "font-size" property. The only change I made was to swap in "voice-family" for "font-size" in my JavaScript code. This same problem exists for all aural (ie, speech related) CSS2 properties listed here: http://www.w3.org/TR/REC-CSS2/aural.html



Reproducible: Always

Steps to Reproduce:
1. Go to https://webspace.utexas.edu/chencl1/clc-4-tts/question.html
2. Click on the "Works" button which will display the CSS font-size property for the h3 element. Notice that the alert box displays the font size used in the CSS stylesheet for h3.
3. Click on the "Doesn't work" button which should display the CSS voice-family property for the h3 element. Notice that the alert box displays nothing even though there is a voice-family set in the CSS stylesheet for h3.

Actual Results:  
Firefox is unable to get the property value for "voice-family" although it can get the property value for "font-size."

Expected Results:  
Firefox is should have retrieved the property value for "voice-family" just as it had retrieved the property value for "font-size."

I am filing this as a new bug in accordance with instructions from this post (https://bugzilla.mozilla.org/show_bug.cgi?id=42417) which say:
"If you have spcial interest in some spcific property or a spcific set of
properties please file them as separate bugs and mark that this bug depends on
the new bug you file."
(Reporter)

Comment 1

12 years ago
Created attachment 203836 [details]
This is the html example file referred to in the bug report.
We don't compute style for voice-family; we probably shouldn't even be parsing it, but that would break some editor-type stuff.

David, I'm tempted to mark this invalid or wontfix; any objections?
(Reporter)

Comment 3

12 years ago
If it isn't being computed, then how should I be accessing the value?
Please let me know. Thank you.

Version: unspecified → 1.5 Branch
Basically, Gecko doesn't know anything about aural properties.  We don't implement them.
There actually is some value in implementing computed style for them -- people could then use Gecko to do various multimodal things.  But we'd probably want to implement the css3 versions of the properties, which have changed a bit, I think.
Assignee: nobody → general
Component: General → DOM: CSSOM
Product: Firefox → Core
QA Contact: general → ian
Version: 1.5 Branch → Trunk

*** This bug has been marked as a duplicate of 47159 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.