Input buttons on top of a background depress slowly.

RESOLVED DUPLICATE of bug 255703

Status

()

Core
Layout: Form Controls
--
minor
RESOLVED DUPLICATE of bug 255703
12 years ago
12 years ago

People

(Reporter: dolphinling, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051120 Firefox/1.6a1

In a game I play, certain submit buttons take a noticable amount of time to depress when clicked. This appears to be because of the background behind them. If it is removed, they work normally, if it's shrunk they speed up partially.

I don't know if this is a regression or not. In 1.8 branch it seemed to work okay at first, then slow down over time. In trunk, it starts slow. I haven't tested 1.7 branch or earlier. I also haven't tested any other OSes.

Somewhat reduced but not minimal testcase coming up.
(Reporter)

Comment 1

12 years ago
Created attachment 203957 [details]
Somewhat reduced testcase
Attachment #203957 - Attachment description: Somewhat reduced tesetcase → Somewhat reduced testcase

Comment 2

12 years ago
The following is sufficient to crawl for me:

<body background="http://images.neopets.com/games/bilgedice/woodbg.gif"></body>

If I make an equivalent gif without transparency, it works fine.

That makes this a dupe

*** This bug has been marked as a duplicate of 255703 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 3

12 years ago
oh, and clicking the button is slow because it triggers a reflow.
You need to log in before you can comment on or make changes to this bug.