Focus changes when typing and page with form completes loading

RESOLVED DUPLICATE of bug 125282

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 125282
12 years ago
12 years ago

People

(Reporter: djstealth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

While I'm typing in a textbox such as the addressbar or the search bar, if a page completes loading, the focus will change.

This happens in other occurances of data entry, potentially (worst-case) I could begin typing in a password somewhere, and would finish typing this in, in a clear-text box, and accidentally submit this somewhere.


Reproducible: Always

Steps to Reproduce:
(simple example with homepage as Firefox default google search page)
1. Load browser, and type in a URL in the address bar
2. Before homepage loads, begin typing in a URL in the addressbar (slow enough so that the page will complete loading while you're still typing)


Actual Results:  
While typing in a URL in the address bar as the home page is loading, as soon as a page (with a form) comes up, the focus will change to the text input box (e.g., search box).  So the begining of the URL is in Address bar and it continues in the text box on the form.

Expected Results:  
A simple solution to this would be as follows:

Detect current typing, and do not change focus until typing is complete.
(For example, prior to changing focus, if there were more than 2 keypresses in the last second, abort [or delay] the focus change; otherwise, change focus)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 125282 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.